If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Downloads do not download into the designated folder

RESOLVED WORKSFORME

Status

()

Firefox
Untriaged
RESOLVED WORKSFORME
6 years ago
6 years ago

People

(Reporter: Robert Munson, Unassigned)

Tracking

9 Branch
x86
Windows Vista
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.0; rv:9.0.1) Gecko/20100101 Firefox/9.0.1
Build ID: 20111220165912

Steps to reproduce:

Using Tools -> Options -> Downloads, I specified a folder (Downloads) under Desktop -> (userid) -> Downloads.  I performed downloads (attachments in emails - gmail, hotmail, yahoo).


Actual results:

The download is placed in a temporary folder.
Users ->(user id) -> AppData -> Local -> Temp




Expected results:

It should have downloaded into the designated folder, not the Temp folder.  Since this is an egregious error, I have tried various things to no avail.  Upgraded to Firefox 9.0.1, changed the target folder to something else and back to Downloads, restarted Firefox, ...running out of things to try.  I did look at Run:  firefox.exe -p but the only profile shown was 'default' and I have never done anything to create special profile options, so I can't imagine how this is working everywhere else, but not for me.  I am on Vista Service Pack 2 on Acer Aspire E380 32-bit OS.  I could do some screen prints to show you that I really did enter a valid folder for my downloads, but I am not going to bother for now.  There must be something really obvious going on, but I have no clue what.
(Reporter)

Comment 1

6 years ago
I should have added Chrome, IE and Safari have no problem downloading to the designated folder.

Comment 2

6 years ago
Does the issue still occur if you start Firefox in Safe Mode? http://support.mozilla.com/en-US/kb/Safe+Mode

How about with a new, empty profile? http://support.mozilla.com/en-US/kb/Basic%20Troubleshooting#w_8-make-a-new-profile

Does the user have read/write access to that folder?

AFAIK -> Firefox saves to the temp location and then moves it to the final destination when the download completes...
Component: General → Untriaged
QA Contact: general → untriaged
(Reporter)

Comment 3

6 years ago
Thanks for the comments/efforts to diagnose.
Yes, the issue still occurs when I restart in Safe Mode.
Yes, the issue still occurs when I run with a newly created default empty profile (I think my other profile is also empty/default, but if not, I don't know where it varies).
Yes, I have read/write access to the desired Download folder.  IE, Chrome and Safari have no trouble writing to it.
Thanks, again.  Any other ideas.
(Reporter)

Comment 4

6 years ago
For what it is worth - I tried one more thing.  Using Tools -> Options -> I changed to 'always ask' where to save it.  Then I did a download, but it didn't ask.  It just went straight to Users ->(user id) -> AppData -> Local -> Temp.  I even changed the 'folder' from 'Downloads' to 'Desktop' (where I would never want my countless downloads to go, but it still delivers them to Users ->(user id) -> AppData -> Local -> Temp.

Since Firefox offers the feature to select where the download goes, there has to be a way, but I can't find the way for the life of me.

Comment 5

6 years ago
Usually this wouldn't apply to a new profile, but try the steps at https://support.mozilla.org/en-US/kb/Preferences%20are%20not%20saved
(Reporter)

Comment 6

6 years ago
(In reply to Tim (fmdeveloper) from comment #5)
> Usually this wouldn't apply to a new profile, but try the steps at
> https://support.mozilla.org/en-US/kb/Preferences%20are%20not%20saved

First steps were easy - did these:
At the top of the Firefox window, click on the Firefox button, go over to the Help menu (on Windows XP, click on the Help menu) and select Troubleshooting Information. The Troubleshooting Information tab will open.
Under the Application Basics section, click on Open Containing Folder. A window with your profile files will open.

But, not finding a user.js file to edit, I hit a dead end.

Update - I initially reported this problem from a Vista computer, but I am now on my laptop, Windows 7.  I have the current version of Firefox (9.0.1), I have selected 'Downloads' as the target folder in which to place my downloads.  Yet they still go into Users ->(user id) -> AppData -> Local -> Temp!?!

I can't believe I am the only one in the world with this problem.  It is not intermittent.  I'm at a complete loss.

Comment 7

6 years ago
Wow, this is weird. Are the downloads fully complete or are they partial downloads?
(Note: this may be a stupid question :p)
(Reporter)

Comment 8

6 years ago
All downloads fully complete - no partials.  They complete into my download folder when using Safari, IE or Chrome.  They download into the Temp folder when using Firefox, in spite of a designated folder saying 'downloads'

Comment 9

6 years ago
Follow the instructions on the site below and ping back with the results please:
http://kb.mozillazine.org/Unable_to_save_or_download_files
(Reporter)

Comment 10

6 years ago
I have worked my way through http://kb.mozillazine.org/Unable_to_save_or_download_files.  Nothing interesting so far.

Choose a different download folder - I had done that before, but did it again.  I changed to 'Desktop' (the last place I want to download to), but it still goes to Temp.

Reset download folder - I went to about:config and the only 'user set' was the download folder itself.  I right clicked and reset.

Clear the download history - check.

Change or reset actions for file types - check.

Remove download manager plugins - Windows - none found.

Disable add-ons - only 2 found (Microsoft.net and Skype, both disabled).

Temporarily disable antivirus or update security software - check.

Temporarily disable antivirus or update security software - not applicable, since I do get a download, just to the wrong place. It always completes.  But I did toggle it to false just for completeness.

Enable downloads blocked by Security Zone Policy - Windows - not applicable.  I am trying to download a pdf file and it works, perfect, just into the wrong folder.  Windows is not blocking anything.
Could you click the button on about:support to copy the contents to the clipboard, paste them in a text file and upload them to this bug?

Thanks.
(Reporter)

Comment 12

6 years ago
Clipboard below:



  Application Basics

        Name
        Firefox

        Version
        10.0.1

        User Agent
        Mozilla/5.0 (Windows NT 6.0; rv:10.0.1) Gecko/20100101 Firefox/10.0.1

        Profile Directory

          Open Containing Folder

        Enabled Plugins

          about:plugins

        Build Configuration

          about:buildconfig

        Crash Reports

          about:crashes

        Memory Use

          about:memory

  Extensions

        Name

        Version

        Enabled

        ID

        Microsoft .NET Framework Assistant
        0.0.0
        false
        {20a82645-c095-46ed-80e3-08825760534b}

        Skype extension for Firefox
        4.2.0.5198
        false
        {AB2CE124-6272-4b12-94A9-7303C7397BD1}

  Modified Preferences

      Name

      Value

        browser.places.smartBookmarksVersion
        2

        browser.startup.homepage_override.buildID
        20120208060813

        browser.startup.homepage_override.mstone
        rv:10.0.1

        extensions.lastAppVersion
        10.0.1

        network.cookie.prefsMigrated
        true

        places.database.lastMaintenance
        1329163089

        places.history.expiration.transient_current_max_pages
        46946

        places.history.expiration.transient_optimal_database_size
        75112448

        privacy.sanitize.migrateFx3Prefs
        true

  Graphics

        Adapter Description
        NVIDIA GeForce 6150SE nForce 430

        Vendor ID
        10de

        Device ID
        03d0

        Adapter RAM
        256

        Adapter Drivers
        nvd3dum

        Driver Version
        8.17.12.8562

        Driver Date
        10-15-2011

        Adapter RAM (GPU #2)
        Unknown

        Adapter Drivers (GPU #2)
        Unknown

        Direct2D Enabled
        false

        DirectWrite Enabled
        false (7.0.6002.18392)

        ClearType Parameters
        ClearType parameters not found

        WebGL Renderer
        Google Inc. -- ANGLE (NVIDIA GeForce 6150SE nForce 430) -- OpenGL ES 2.0 (ANGLE 0.0.0.809)

        GPU Accelerated Windows
        0/1. Blocked for your graphics card because of unresolved driver issues.
Thanks Robert, I don't see any obviously problems there.

Can you see if you have any plugins installed that could be causing this?  Plugins are enabled in safe-mode and in new profiles so that could be why the problem persisted. You can also try with all plugins disabled.

Does this problem only apply to certain types of files?  It's possible that your preferences are set to always open those types of files rather than ask. See https://support.mozilla.org/en-US/kb/Options%20window%20-%20Applications%20panel
(Reporter)

Comment 14

6 years ago
Thanks for continuing to probe.  You found the 'problem'.

I first tried plugins.  I have 17 seemingly harmless plug-ins.  I disabled all 17 and the problem remains.

I then tried:
https://support.mozilla.org/en-US/kb/Options%20window%20-%20Applications%20panel

There, I learned, unlike Chrome and IE - when a file type is set to 'always open with' it opens it, but places it in a temp folder rather than the designated download folder.  So, most common file types have an 'always open with' default set up.  When that is used, the download goes to temp.  If I simply say 'save file' the download appears in the target folder.

Again, this is not how Chrome works (the download goes into the target folder regardless of 'always open with') but, no big deal.  Now I know.  You can close this problem.  Problem solved.  Thanks for your efforts.

Updated

6 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
Thanks for following up on this issue, Robert!
You need to log in before you can comment on or make changes to this bug.