Closed Bug 714923 Opened 8 years ago Closed 8 years ago

When adding many properties to an object in a web worker, processing fails silently

Categories

(Core :: DOM: Core & HTML, defect)

12 Branch
x86
macOS
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 711388

People

(Reporter: david, Unassigned)

References

()

Details

I'm writing a simple app to parse very large files containing hundreds of thousands of lines. I started using a naive approach of adding a property for each line. Strangely when I do this in a web worker, processing fails silently for me in Firefox (works fine in Chrome). Adding the same properties to an object on the main thread completes fine.

There's no error reported via the onerror handler, nor in the error console. I've provided a simplified test case which reproduces reliably for me available at:
http://downloads.illsley.org/temp/bigobject.html

The buttons up to 100,000 work fine for me, but the 1,000,000 in the web worker never receives the completed message.
WARNING: Out of memory!: file mozilla/dom/workers/WorkerPrivate.cpp, line 3233
We need bug 711388 fixed.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 711388
You need to log in before you can comment on or make changes to this bug.