segmentation fault opening multiple windows in rapid succession

RESOLVED FIXED

Status

()

Core
Networking: Cache
--
critical
RESOLVED FIXED
17 years ago
17 years ago

People

(Reporter: Leston Buell, Assigned: gordon)

Tracking

({crash})

Trunk
x86
Linux
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [cache], URL)

(Reporter)

Description

17 years ago
I'm using Linux, so the middle button on my mouse opens a new window when i
click on a link. If i quickly middle-click on two or three links before any new
windows show up (which is easy to do, at least on my machine), i get a
segmentation fault. Here is the message from my console. 

JavaScript error:
 line 0: uncaught exception: 
 Scrollbars in this skin are not properly supporting
 mac smart-scrolling prefs!

Error loading URL about:blank: 804b0002
/usr/local/mozilla/run-mozilla.sh:
   line 72:   
      6976 Segmentation fault      $prog ${1+"$@"}

This is with build 2001030813, but i have been seeing this problem for several days.
Linux build 2001-03-12-05 here.  can't get it to crash... I brought up about 20
windows, in bursts of 3-4 (click on 3-4 links, then first of those 3-4 windows
opens).  No crash.

Comment 2

17 years ago
Reporter this still occuring in the latest nightlies?
Severity: major → critical
Keywords: crash
(Reporter)

Comment 3

17 years ago
Sorry, i'm the reporter, but i didn't notice the last two posts on this bug.

I investigated this more upon reading that people couldn't duplicate this bug. I
didn't realize that i was only getting this with Ebay pages. This is the only
place i'm seeing it. To see this, go to, say, the "Bear Accessories" page
(everyone's favourite) on Ebay at:

<http://listings.ebay.com/aw/listings/list/category387/index.html>

Quickly middle click (or whatever you do to open in new window) and three or
four auction items. The browser should crash. Actually, i have recently learnt
that i can even get it to crash by opening just one link in a new window and
another link in the original window.

The build i'm currently using is Linux 2001032908.

Comment 4

17 years ago
Leston, thanks for the follow-up.  With your latest steps to reproduce I was
able to reproduce this crash.

Steps I took were to open about five of the auction item links in new windows
using middle mouse click) and then close all of those windows, leaving only the
original open.  Then I clicked on one of the links in the original window and
loaded it in teh same window.  This elicited the crash I believe the reporter is
seeing.  

Talkback gives pretty incomplete data on this but enough to get the bug over to
the correct Component I think.  Reassigning to Networking: Cache.

 nsDiskCacheDevice::FindEntry()             nsCacheService::SearchCacheDevices()
            nsCacheService::ActivateEntry()            
nsCacheService::ProcessRequest()             nsCacheService::OpenCacheEntry()  
          nsCacheSession::AsyncOpenCacheEntry()            
nsHTTPChannel::OpenCacheEntry()             nsHTTPChannel::Connect()           
 nsHTTPChannel::AsyncOpen()             nsStreamLoader::Init()            
NS_NewStreamLoader()             HTMLContentSink::ProcessSCRIPTTag()           
 HTMLContentSink::AddLeaf()             CNavDTD::AddLeaf()            
CNavDTD::HandleScriptToken()             CNavDTD::OpenContainer()            
CNavDTD::HandleDefaultStartToken()             CNavDTD::HandleStartToken()     
       CNavDTD::HandleToken()             CNavDTD::BuildModel()            
nsParser::BuildModel()             nsParser::ResumeParse()            
nsParser::ContinueParsing()             HTMLContentSink::OnStreamComplete()    
        nsStreamLoader::OnStopRequest()            
nsHTTPFinalListener::OnStopRequest()            
nsStreamListenerTee::OnStopRequest()            
nsHTTPChannel::ResponseCompleted()            
nsHTTPServerListener::OnStopRequest()            
nsOnStopRequestEvent::HandleEvent()            
nsStreamObserverEvent::HandlePLEvent()             PL_HandleEvent()            
PL_ProcessPendingEvents()             nsEventQueueImpl::ProcessPendingEvents() 
           event_processor_callback()             our_gdk_io_invoke()          
  libglib-1.2.so.0 + 0xeaca (0x40635aca)             libglib-1.2.so.0 + 0x10186
(0x40637186)             libglib-1.2.so.0 + 0x10751 (0x40637751)            
libglib-1.2.so.0 + 0x108f1 (0x406378f1)             libgtk-1.2.so.0 + 0x8c8e9
(0x4055f8e9)             nsAppShell::Run()             nsAppShellService::Run()
            main1()             main()             libc.so.6 + 0x189cb
(0x402489cb)  
Assignee: asa → gordon
Status: UNCONFIRMED → NEW
Component: Browser-General → Networking: Cache
Ever confirmed: true
QA Contact: doronr → tever
(Assignee)

Updated

17 years ago
Whiteboard: [cache]
(Assignee)

Comment 5

17 years ago
We just landed the DISKCACHE1_BRANCH last night, which fixes a number of
problems in the cache.  I was not able to reproduce this bug with my latest
build, so I'm marking it FIXED.

Please try this with a build from 2001/04/04 or later, and reopen the bug if it
still occurs.

Thanks.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.