Landings to necko cause PSM 2.0 to not work

VERIFIED FIXED in mozilla0.8.1

Status

()

Core
Networking: HTTP
VERIFIED FIXED
18 years ago
17 years ago

People

(Reporter: Javier Delgadillo, Assigned: Darin Fisher)

Tracking

Trunk
mozilla0.8.1
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

18 years ago
This is bug is for tracking PSM 2.0 inter-operability with necko.

The recent landings to necko have caused https to no longer work with PSM 2.0
and mozilla trunk builds.

SSL/IMAP still works.  From my debugging, a call to PSM 2.0's write method
returns PR_WOULD_BLOCK_ERROR then necko never tries to write again.
(Assignee)

Comment 1

18 years ago
Strange that SSL/Imap works bug HTTPS does not... they both use sSocketTransport
right??
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla0.8.1
(Reporter)

Comment 2

18 years ago
Forcing the handshake on the SSL connection causes everything to "just work".

Just talked to nelsonb and he told me there was no upside or downside to forcing
the handshake for all client connections withing PSM 2.0

Unless someone can think of a reason to not force the handshake on all
connections in PSM 2.0, then that may be our solutiong.

For the record, I forced the handshake in my build, and https and SSL/IMAP still
work.  But I haven't done any testing of SSL/SMTP since PSM 2.0 still chooses
the wrong cert for me.

Comment 3

18 years ago
Forcing the handshake causes the thread to block until the handshake is done.

(Assignee)

Comment 4

18 years ago
Yeah... I don't think you want to block the socket thread for this.  It might
simplify things for the socket transport, but responsiveness would suffer --
though I'm not sure if this "suffering" would be measureable.
(Assignee)

Comment 5

18 years ago
Created attachment 27355 [details] [diff] [review]
Fixes problem
(Assignee)

Comment 6

18 years ago
Created attachment 27356 [details] [diff] [review]
Fixes problem
(Assignee)

Comment 7

18 years ago
Created attachment 27357 [details] [diff] [review]
Fixes problem
(Assignee)

Comment 8

18 years ago
I got a little trigger happy when submitting the attachment (patch repeated
three times!).  Anyways, this bug was regression from my patch for bug 66516.
r=bryner

Comment 10

18 years ago
sr=mscott
(Assignee)

Comment 11

18 years ago
fix checked in.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 12

17 years ago
VERIFIED:

HTTPS seems to be working overall in Mozilla 0.9.

cc: security's' default qa contact in case this should not be verified.
Status: RESOLVED → VERIFIED
QA Contact: tever → benc
You need to log in before you can comment on or make changes to this bug.