put admin1a/b into service as NTP servers

RESOLVED FIXED

Status

RESOLVED FIXED
7 years ago
5 years ago

People

(Reporter: dustin, Assigned: mlarrain)

Tracking

Details

These hosts should replace ns1/2 for this purpose.
Assignee: server-ops-releng → mlarrain

Comment 1

7 years ago
These changes should be made in puppet. Change the IPs in modules/ntp/manifests/server.pp and also in init.pp

Then make sure and add the ntp::server class to those hosts' node definitions. The rest should all work itself on its own then, but I'd expect lots of nagios alerts while the changes actually happen, as those are very sensitive. The nagios checks should probably also be updated to check against those servers.
(Assignee)

Comment 2

7 years ago
I have added these to puppet and everything seems to be working now :)
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
(Assignee)

Updated

7 years ago
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 3

7 years ago
02:24 < dustin> you need to use tcpdump (udp port 123) to check what's still talking to ns1/2
02:24 < dustin> and fix that
02:24 < dustin> and then remove ns1/2 from the peers list in puppet
02:25 < dustin> and remove 'include ntp::server' from ns1/2's node definition
(Assignee)

Comment 4

7 years ago
roled dns over to use ntp from admin1a and admin1b yesterday. Will run tcpdump on ns1|2 on Monday to see if anything hasn't switched over and fix it accordingly.
(Assignee)

Comment 5

7 years ago
from doing a tcpdump it looks like the mgmt interfaces of a few devices still are talking to ns1|2.
(Assignee)

Comment 6

7 years ago
rolled NTP fully over to admin1a|b
Status: REOPENED → RESOLVED
Last Resolved: 7 years ago7 years ago
Resolution: --- → FIXED
Component: Server Operations: RelEng → RelOps
Product: mozilla.org → Infrastructure & Operations
You need to log in before you can comment on or make changes to this bug.