Last Comment Bug 715113 - Pull updated Snappy revision (>=r56)
: Pull updated Snappy revision (>=r56)
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: DOM (show other bugs)
: 12 Branch
: x86 Linux
: -- normal (vote)
: mozilla12
Assigned To: Rogério Gonçalves
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-01-04 05:55 PST by Rogério Gonçalves
Modified: 2012-01-05 11:49 PST (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch to this bug. (1.13 KB, patch)
2012-01-04 06:21 PST, Rogério Gonçalves
no flags Details | Diff | Review
Update snappy to r56 (24.67 KB, patch)
2012-01-05 07:38 PST, Kyle Huey [:khuey] (khuey@mozilla.com)
bent.mozilla: review+
Details | Diff | Review

Description Rogério Gonçalves 2012-01-04 05:55:38 PST
User Agent: Mozilla/5.0 (Ubuntu; X11; Linux i686; rv:9.0.1) Gecko/20100101 Firefox/9.0.1
Build ID: 20111221215619

Steps to reproduce:

Compiling firefox nightly code with debug mode enabled (ac_add_options --enable-debug on mozconfig)
gcc-4.3.real (Ubuntu 4.3.5-3ubuntu1) 4.3.5
Ubuntu 10.10


Actual results:

/mozilla-central/other-licenses/snappy/src/snappy.cc:504: error: extra ‘;’
mozilla-central/other-licenses/snappy/src/snappy.cc:590: error: extra ‘;’



Expected results:

Finish the compilation process.
Comment 1 Rogério Gonçalves 2012-01-04 06:21:54 PST
Created attachment 585728 [details] [diff] [review]
Patch to this bug.
Comment 2 Ben Turner (not reading bugmail, use the needinfo flag!) 2012-01-04 07:56:16 PST
Comment on attachment 585728 [details] [diff] [review]
Patch to this bug.

Snappy is a library we pull from google, this issue needs to be reported to them:

https://code.google.com/p/snappy/issues/list
Comment 3 Rogério Gonçalves 2012-01-04 08:42:51 PST
Ok.
I reported the error on the snappy site:
https://code.google.com/p/snappy/issues/detail?id=58
Comment 4 Rogério Gonçalves 2012-01-04 08:57:34 PST
The answer obtained on snappy issue:
--
Hi,

This is not an error in Snappy; it is not illegal C++, but it probably stops Firefox compile anyway due to -Werror. (I haven't checked that they actually compile with -Werror.) However, these warnings were already reported in  bug 57 , and the warning was fixed in r56.
--
https://code.google.com/p/snappy/source/detail?r=56
Comment 5 Kyle Huey [:khuey] (khuey@mozilla.com) 2012-01-04 10:02:19 PST
Re-summarizing the bug.
Comment 6 :Gavin Sharp [email: gavin@gavinsharp.com] 2012-01-04 10:30:53 PST
r56 seems to only fix one of the instances touched in Rogerio's patch.
Comment 7 Ben Turner (not reading bugmail, use the needinfo flag!) 2012-01-04 10:40:19 PST
Kyle tells me that we don't compile with -Werror... Are you using special compile flags? Or maybe WARNINGS_AS_ERRORS in your mozconfig?
Comment 8 Kyle Huey [:khuey] (khuey@mozilla.com) 2012-01-04 10:40:44 PST
Rogerio, do you have -Werror in your CFLAGS/CXXFLAGS in your environment?  As far as I can tell we shouldn't be building Snappy with -Werror by default.
Comment 9 Rogério Gonçalves 2012-01-04 11:38:42 PST
The content of my mozconfig:
  ac_add_options --enable-debug

Don't have WARNINGS_AS_ERRORS.

Environment vars CFLAGS/CXXFLAGS don't have -Werror.
Comment 10 Rogério Gonçalves 2012-01-05 07:28:02 PST
I checked out snappy code on mozilla-central/other-licenses/snappy/src (svn checkout http://snappy.googlecode.com/svn/trunk/ src)
The error doesn't occur on compiling process.
Comment 11 Kyle Huey [:khuey] (khuey@mozilla.com) 2012-01-05 07:31:26 PST
Ok, if pulling an updated upstream rev fixes it I don't care to worry about why it's broken.
Comment 12 Ben Turner (not reading bugmail, use the needinfo flag!) 2012-01-05 07:32:33 PST
Please make sure you follow the steps outlined in other-licenses/snappy/README too.
Comment 13 Kyle Huey [:khuey] (khuey@mozilla.com) 2012-01-05 07:38:32 PST
Created attachment 586069 [details] [diff] [review]
Update snappy to r56
Comment 14 :Ms2ger 2012-01-05 07:40:32 PST
Yw.
Comment 15 Ben Turner (not reading bugmail, use the needinfo flag!) 2012-01-05 08:08:56 PST
Comment on attachment 586069 [details] [diff] [review]
Update snappy to r56

Looks fine, let's add the revision number and instructions to update it to README also.
Comment 16 Kyle Huey [:khuey] (khuey@mozilla.com) 2012-01-05 09:39:03 PST
https://hg.mozilla.org/mozilla-central/rev/b0e65467c4c8
Comment 17 Ted Mielczarek [:ted.mielczarek] 2012-01-05 11:49:50 PST
This was probably broken because we compile with -pedantic, FWIW. (I've hit the same problem with Breakpad code.)

Note You need to log in before you can comment on or make changes to this bug.