No Drag and Drop in Google Maps When You Are Behind A Proxy That Requires Authentication

RESOLVED DUPLICATE of bug 627616

Status

()

Core
DOM: Core & HTML
RESOLVED DUPLICATE of bug 627616
6 years ago
6 years ago

People

(Reporter: Gerd, Unassigned)

Tracking

({regression})

9 Branch
x86
Windows XP
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

6 years ago
Created attachment 585743 [details]
current behavior

User Agent: Mozilla/5.0 (Windows NT 5.1; rv:9.0.1) Gecko/20111221 Firefox/9.0.1
Build ID: 20111222072036

Steps to reproduce:

Opened Google Maps to enter a route between two locations.


Actual results:

Route was displayed but without the Drag And Drop functionality to change the computed route. Instead, dragging moved the entire map around.


Expected results:

On hovering the mouse pointer over the blue route, a tool tip saying "click and drag to change route" as well as a small circle around the mouse pointer should have appeared. Dragging the route should then change the displayed route (blue line).
(Reporter)

Comment 1

6 years ago
Created attachment 585744 [details]
expected behavior
(Reporter)

Comment 2

6 years ago
Important note for this bug:

The described behavior only occurs if Firefox operates behind a proxy which requires authentication. 
The following error messages appear in the Web Console already when Google Maps is loaded:

[20:55:53.119] GET https://maps.google.com/images/experiments/nav_logo78.png [HTTP/1.1 407 Proxy Authentication Required 0ms]
[20:55:54.991] GET https://maps.google.com/maps/gen_204?imp=ael&jsv=386c [HTTP/1.1 407 Proxy Authentication Required 0ms]
[20:55:56.173] GET https://maps.google.com/maps/gen_204?imp=mapsgl:promo:show&ei=R10DT6zCDM7J_AblwOSlCA [HTTP/1.1 407 Proxy Authentication Required 0ms]

After a route was entered and computed, the following messages appear in the Web Console when the page is rendered:

[15:26:26.816] GET https://maps.gstatic.com/mapfiles/markers2/red_markers_A_J2.png [HTTP/1.1 407 Proxy Authentication Required 0ms]
[15:26:26.833] GET https://maps.gstatic.com/mapfiles/markers2/shadow50.png [HTTP/1.1 407 Proxy Authentication Required 0ms]
[15:26:27.213] GET https://maps.gstatic.com/mapfiles/markers2/shadow50.png [HTTP/1.1 407 Proxy Authentication Required 0ms]
[15:26:27.264] GET https://maps.gstatic.com/mapfiles/markers2/markerTransparent.png [HTTP/1.1 407 Proxy Authentication Required 0ms]
[15:26:44.612] GET https://maps.gstatic.com/mapfiles/transparent.png [HTTP/1.1 407 Proxy Authentication Required 15ms]
[15:26:44.629] GET https://maps.google.de/maps/trends?output=thumbnails&panoramio=11797888&client=maps [HTTP/1.1 407 Proxy Authentication Required 15ms]
[15:26:45.487] GET https://maps.gstatic.com/mapfiles/markers2/red_markers_A_J2.png [HTTP/1.1 407 Proxy Authentication Required 0ms]
[15:26:45.538] GET https://maps.gstatic.com/mapfiles/markers2/shadow50.png [HTTP/1.1 407 Proxy Authentication Required 15ms]
[15:26:45.599] GET https://maps.gstatic.com/mapfiles/markers2/markerTransparent.png [HTTP/1.1 407 Proxy Authentication Required 0ms]
[15:26:45.660] GET https://maps.gstatic.com/mapfiles/markers2/markers_A_J2_B254FD.png [HTTP/1.1 200 OK 0ms]
[15:26:45.732] GET https://maps.gstatic.com/mapfiles/markers2/shadow50.png [HTTP/1.1 407 Proxy Authentication Required 0ms]
[15:26:45.768] GET https://maps.gstatic.com/mapfiles/markers2/markerTransparent.png [HTTP/1.1 407 Proxy Authentication Required 0ms]
[15:26:45.884] GET https://maps.gstatic.com/mapfiles/markers2/red_markers_A_J2.png [HTTP/1.1 407 Proxy Authentication Required 0ms]
[15:26:45.969] GET https://maps.gstatic.com/mapfiles/markers2/shadow50.png [HTTP/1.1 407 Proxy Authentication Required 0ms]
[15:26:46.003] GET https://maps.gstatic.com/mapfiles/markers2/markerTransparent.png [HTTP/1.1 407 Proxy Authentication Required 0ms]
[15:26:47.312] GET https://maps.gstatic.com/mapfiles/markers2/markers_A_J2_B254FD.png [HTTP/1.1 407 Proxy Authentication Required 16ms]
[15:26:47.364] GET https://maps.gstatic.com/mapfiles/markers2/markers_A_J2_B254FD.png [HTTP/1.1 407 Proxy Authentication Required 0ms]
[15:26:53.888] GET https://maps.gstatic.com/mapfiles/markers2/red_markers_A_J2.png [HTTP/1.1 407 Proxy Authentication Required 0ms]
[15:26:53.930] GET https://maps.gstatic.com/mapfiles/markers2/shadow50.png [HTTP/1.1 407 Proxy Authentication Required 0ms]
[15:26:53.969] GET https://maps.gstatic.com/mapfiles/markers2/markerTransparent.png [HTTP/1.1 407 Proxy Authentication Required 0ms]
[15:26:54.063] GET https://maps.gstatic.com/mapfiles/markers2/shadow50.png [HTTP/1.1 407 Proxy Authentication Required 0ms]
[15:26:54.115] GET https://maps.gstatic.com/mapfiles/markers2/markerTransparent.png [HTTP/1.1 407 Proxy Authentication Required 0ms]
[15:26:54.185] GET https://maps.gstatic.com/mapfiles/markers2/shadow50.png [HTTP/1.1 407 Proxy Authentication Required 0ms]
[15:26:54.387] GET https://maps.gstatic.com/mapfiles/markers2/red_markers_A_J2.png [HTTP/1.1 407 Proxy Authentication Required 0ms]
[15:26:54.432] GET https://maps.gstatic.com/mapfiles/markers2/markerTransparent.png [HTTP/1.1 407 Proxy Authentication Required 0ms]
[15:26:54.840] GET https://maps.gstatic.com/mapfiles/markers2/markers_A_J2_ABE457.png [HTTP/1.1 407 Proxy Authentication Required 0ms]
[15:27:05.919] GET https://maps.gstatic.com/mapfiles/markers2/shadow50.png [HTTP/1.1 407 Proxy Authentication Required 16ms]
[15:27:05.975] GET https://maps.gstatic.com/mapfiles/markers2/markerTransparent.png [HTTP/1.1 407 Proxy Authentication Required 0ms]
[15:27:06.024] GET https://maps.gstatic.com/mapfiles/markers2/shadow50.png [HTTP/1.1 407 Proxy Authentication Required 0ms]
[15:27:06.084] GET https://maps.gstatic.com/mapfiles/markers2/markerTransparent.png [HTTP/1.1 407 Proxy Authentication Required 0ms]
[15:27:06.145] GET https://maps.gstatic.com/mapfiles/transparent.png [HTTP/1.1 407 Proxy Authentication Required 0ms]
[15:27:06.227] GET https://maps.gstatic.com/mapfiles/markers2/red_markers_A_J2.png [HTTP/1.1 407 Proxy Authentication Required 0ms]
[15:27:06.262] GET https://maps.gstatic.com/mapfiles/markers2/shadow50.png [HTTP/1.1 407 Proxy Authentication Required 0ms]
[15:27:06.311] GET https://maps.gstatic.com/mapfiles/markers2/markerTransparent.png [HTTP/1.1 407 Proxy Authentication Required 0ms]
[15:27:06.971] GET https://maps.gstatic.com/mapfiles/markers2/marker_greenA.png [HTTP/1.1 407 Proxy Authentication Required 0ms]
[15:27:07.028] GET https://maps.gstatic.com/mapfiles/markers2/marker_greenB.png [HTTP/1.1 407 Proxy Authentication Required 0ms]
[15:27:07.089] GET https://maps.gstatic.com/mapfiles/markers2/dd-via.png [HTTP/1.1 407 Proxy Authentication Required 0ms]
[15:27:07.488] GET https://maps.gstatic.com/mapfiles/markers2/dd-via.png [HTTP/1.1 407 Proxy Authentication Required 0ms]
[15:27:07.541] GET https://maps.gstatic.com/mapfiles/markers2/drag_cross_67_16.png [HTTP/1.1 407 Proxy Authentication Required 0ms]
[15:27:07.597] GET https://maps.gstatic.com/mapfiles/markers2/dd-via-transparent.png [HTTP/1.1 407 Proxy Authentication Required 0ms]
(Reporter)

Comment 3

6 years ago
A similar problem is described here:

https://support.mozilla.org/hy-AM/questions/895226 (note the replies)
(Reporter)

Updated

6 years ago
Keywords: regression
See Also: → bug 517737
(Reporter)

Updated

6 years ago
Summary: No Drag and Drop in Google Maps When You Are Behind A Proxy That Requires Authorization → No Drag and Drop in Google Maps When You Are Behind A Proxy That Requires Authentication

Comment 4

6 years ago
Thanks! Since you're able to reproduce this problem, could you help us find a regression range? http://mozilla.github.com/mozregression/ is a tool that will help you narrow the problem down to an isolated range. Just give it 2011-09-27 for the good date, and 2011-11-08 for the bad one, and we should be able to find a specific nightly build in which this bug appeared.
(Reporter)

Comment 5

6 years ago
Unfortunately, the mozregression tool cannot be set up properly here because of the proxy I already mentioned. 
Setting options like http_proxy, proxy_user and proxy_password in wget.ini did not help.
However, I was able to track down the regression window manually: 

Last good build: 2011-08-11 (2011-08-11-03-07-59)
First bad build: 2011-08-12 (2011-08-12-03-07-44)

Comment 6

6 years ago
Any chance you could get the hg revision from about:buildconfig for those two builds?
(Reporter)

Comment 8

6 years ago
Amendment:

I also tried

$ export http_proxy=http://myusername:mypassword@myproxy.mydomain:proxyport

but only got

Searching for mozregression
Reading http://pypi.python.org/simple/mozregression/
No local packages or download links found for mozregression
Best match: None
(Reporter)

Comment 9

6 years ago
Here are the results from about:buildconfig :

Last good build:

Source

Built from http://hg.mozilla.org/mozilla-central/rev/be17ceae8d60
Build platform
target
i686-pc-mingw32
Build tools
Compiler 	Version 	Compiler flags
d;D:\mozilla-build\msys\mozilla-build\python25\python2.5.exe -O e;D:\mozilla-build\msys\builds\moz2_slave\m-cen-w32-ntly\build\build\cl.py cl 	14.00.50727.762 	-TC -nologo -W3 -Gy -Fdgenerated.pdb -we4553 -DNDEBUG -DTRIMMED -Zi -Zi -UDEBUG -DNDEBUG -GL -wd4624 -wd4952 -O1
d;D:\mozilla-build\msys\mozilla-build\python25\python2.5.exe -O e;D:\mozilla-build\msys\builds\moz2_slave\m-cen-w32-ntly\build\build\cl.py cl 	14.00.50727.762 	-TP -nologo -W3 -Gy -Fdgenerated.pdb -wd4800 -we4553 -DNDEBUG -DTRIMMED -Zi -Zi -UDEBUG -DNDEBUG -GL -wd4624 -wd4952 -O1
Configure arguments

--enable-application=browser --enable-update-channel=nightly --enable-update-packaging --enable-jemalloc --enable-tests

First bad build:

Source

Built from http://hg.mozilla.org/mozilla-central/rev/f262c389193e
Build platform
target
i686-pc-mingw32
Build tools
Compiler 	Version 	Compiler flags
d;D:\mozilla-build\msys\mozilla-build\python25\python2.5.exe -O e;D:\mozilla-build\msys\builds\moz2_slave\m-cen-w32-ntly\build\build\cl.py cl 	14.00.50727.762 	-TC -nologo -W3 -Gy -Fdgenerated.pdb -we4553 -DNDEBUG -DTRIMMED -Zi -Zi -UDEBUG -DNDEBUG -GL -wd4624 -wd4952 -O1
d;D:\mozilla-build\msys\mozilla-build\python25\python2.5.exe -O e;D:\mozilla-build\msys\builds\moz2_slave\m-cen-w32-ntly\build\build\cl.py cl 	14.00.50727.762 	-TP -nologo -W3 -Gy -Fdgenerated.pdb -wd4800 -we4553 -DNDEBUG -DTRIMMED -Zi -Zi -UDEBUG -DNDEBUG -GL -wd4624 -wd4952 -O1
Configure arguments

--enable-application=browser --enable-update-channel=nightly --enable-update-packaging --enable-jemalloc --enable-tests --enable-js-diagnostics
Hmm, the only entries in that list that look suspicious are http://hg.mozilla.org/mozilla-central/rev/0cf822d12c64 (bug 674571) and http://hg.mozilla.org/mozilla-central/rev/16a79c640966 (bug 676413). I'll put together two try builds with each patch backed out for further testing.
A build without the patches of bug 676413 will be available at http://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/josh@joshmatthews.net-650360a67b5f . If that doesn't work, we can start bisecting the rest, because bug 674571 cannot be easily backed out of the current mozilla-central.
To clarify, the build will be available in a few hours.
Nevermind, there was a build error. The new try build should appear at http://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/josh@joshmatthews.net-73f292537347 in a couple hours.
(Reporter)

Comment 14

6 years ago
Just installed and tried this build and the described error seems to have gone. Dragging routes in Google Maps works as expected.
(Reporter)

Comment 15

6 years ago
A few 407's are still there in the Web console, however, it seems that the affected items are then transferred correctly upon a second attempt:

[12:12:38.227] GET http://khm0.google.com/kh/v=101&x=268&y=174&z=9&s=Ga [HTTP/1.1 407 Proxy Authentication Required 15ms]
[12:12:38.278] GET http://khm0.google.com/kh/v=101&x=268&y=174&z=9&s=Ga [HTTP/1.1 407 Proxy Authentication Required 0ms]
[12:12:38.302] GET http://khm1.google.com/kh/v=101&x=267&y=175&z=9&s= [HTTP/1.1 407 Proxy Authentication Required 0ms]
[12:12:38.386] GET http://khm1.google.com/kh/v=101&x=267&y=175&z=9&s= [HTTP/1.1 200 OK 16ms]
[12:12:38.410] GET http://khm0.google.com/kh/v=101&x=268&y=174&z=9&s=Ga [HTTP/1.1 200 OK 16ms]
[12:12:38.433] GET http://khm1.google.com/kh/v=101&x=267&y=173&z=9&s=Galile [HTTP/1.1 200 OK 0ms]
[12:12:38.471] GET http://khm0.google.com/kh/v=101&x=266&y=174&z=9&s=Gali [HTTP/1.1 407 Proxy Authentication Required 0ms]
[12:12:38.562] GET http://khm0.google.com/kh/v=101&x=266&y=174&z=9&s=Gali [HTTP/1.1 200 OK 15ms]
Thank you Gerd, that's an important result! Looks like this was broken by bug 676413.
Blocks: 676413
Component: General → DOM: Core & HTML
Product: Firefox → Core
QA Contact: general → general
Google uses crossOrigin="" all over the place, iirc (which per spec means "Anonymous").

This looks like basically a duplicate of bug 701019 or bug 627616.  The patch in bug 627616 would fix this, I bet, but it's blocked on someone finding time to write a test...  Josh, might you have the bandwidth for that?
Depends on: 627616
Sure, I'll give it a shot.
(Reporter)

Comment 19

6 years ago
Just wondering: Are there any news?
I'm working on a test for bug 627616 that will enable the fix for this bug to land. That is all.
(Reporter)

Comment 21

6 years ago
How do things move forward? Reason for asking is that I am still using the test build provided in comment #13 and it would be nice if an update to later versions was possible without introducing the current bug again.
I expect to be landing the fix for this bug within the next two days. It's just waiting on Honza's review.
(In reply to Josh Matthews [:jdm] from comment #22)
> I expect to be landing the fix for this bug within the next two days. It's
> just waiting on Honza's review.

If you mean bug 627616, it has already been done ;)
(Reporter)

Comment 24

6 years ago
Dear Honza,

that is great. But it seems that there are still some obstacles left. If I could be of some help, too, please let me know.
(In reply to Gerd from comment #24)
> Dear Honza,
> 
> that is great. But it seems that there are still some obstacles left. If I
> could be of some help, too, please let me know.

I'll return back to you later (bug noted).

In the mean time:
- are the symptoms you open this bug for the same with the latest nightly build? (http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-trunk/)
- can you also test (also with a nightly build) with the same Firefox profile (actually on the same machine) while not being behind a proxy that needs authentication?

Thanks.
(Reporter)

Comment 26

6 years ago
Just tested with the latest nightly build.
about:buildconfig
Build Machine

w32-ix-slave42
Source

Built from http://hg.mozilla.org/mozilla-central/rev/7d0d1108a14e
Build platform
target
i686-pc-mingw32
Build tools
Compiler 	Version 	Compiler flags
d;D:\mozilla-build\msys\mozilla-build\python25\python2.5.exe -O e;D:\mozilla-build\msys\builds\moz2_slave\m-cen-w32-ntly\build\build\cl.py cl 	16.00.30319.01 	-TC -nologo -W3 -Gy -Fdgenerated.pdb -we4553 -DNDEBUG -DTRIMMED -Zi -UDEBUG -DNDEBUG -GL -wd4624 -wd4952 -O1 -Oy
d;D:\mozilla-build\msys\mozilla-build\python25\python2.5.exe -O e;D:\mozilla-build\msys\builds\moz2_slave\m-cen-w32-ntly\build\build\cl.py cl 	16.00.30319.01 	-TP -nologo -W3 -Gy -Fdgenerated.pdb -wd4800 -we4553 -DNDEBUG -DTRIMMED -Zi -UDEBUG -DNDEBUG -GL -wd4624 -wd4952 -O1 -Oy
Configure arguments

--enable-update-channel=nightly --enable-update-packaging --enable-jemalloc --enable-signmar --enable-js-diagnostics

And it seems that the bug is gone with that version. Will follow up later with proxy disabled since this will need some configuration changes here.
I think we can safely call this a duplicate of 627616, since the symptoms disappeared after it landed.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 627616
(Reporter)

Comment 28

6 years ago
Apparently, the fix for this bug couldn't make it into the new 12.0 release. That's quite a pity...
That's correct.  The fix is in 13.
You need to log in before you can comment on or make changes to this bug.