Changing fonts causes browser crash

VERIFIED DUPLICATE of bug 68208

Status

VERIFIED DUPLICATE of bug 68208
18 years ago
14 years ago

People

(Reporter: ji, Assigned: asa)

Tracking

Trunk
All
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
build: 03/08 win32, linux and Mac builds

Browser crashes when changing fonts from Edit | Preferences.

Steps to reproduce:
1. Launch browser.
2. Select Edit | Preferences
3. Select Fonts under Appearence
4. Select a different font for Serif/Sans Serif/Monospace
Browser crashes. It's not always reproduciable, but pretty offen, about 8 out of
10 times.
(Reporter)

Comment 1

18 years ago
Below is the stack:
Incident ID: 26835827
 Trigger Type:  Program Crash 
 Trigger Reason:  SIGSEGV: Segmentation Fault: (signal 11) 
 Call Stack:    (Signature = 0x00350034 792633c2)     
     0x00350034 
    libwidget_gtk.so + 0x22ea6 (0x404acea6)
     libX11.so.6 + 0x66683 (0x406bf683)
     libX11.so.6 + 0x65e16 (0x406bee16) 
     libX11.so.6 + 0x65ee6 (0x406beee6) 
     libX11.so.6 + 0x7a142 (0x406d3142) 
     libX11.so.6 + 0x7af85 (0x406d3f85)
     libX11.so.6 + 0x7afbf (0x406d3fbf) 
     libX11.so.6 + 0x689a9 (0x406c19a9) 
     libX11.so.6 + 0x4913f (0x406a213f)
     libgdk-1.2.so.0 + 0x1adab (0x40610dab)
     libwidget_gtk.so + 0x231c8 (0x404ad1c8)
     libwidget_gtk.so + 0x1c459 (0x404a6459)
     libwidget_gtk.so + 0x1d64a (0x404a764a) 
     libwidget_gtk.so + 0x190ea (0x404a30ea) 
     libwidget_gtk.so + 0x1d44f (0x404a744f) 
     libwidget_gtk.so + 0x1d30f (0x404a730f)
     libwidget_gtk.so + 0x25c40 (0x404afc40) 
     libwidget_gtk.so + 0x19028 (0x404a3028)
     libwidget_gtk.so + 0x1d0e4 (0x404a70e4)
     nsCOMPtr_base::~nsCOMPtr_base() 
     libnsappshell.so + 0x87e0 (0x4036c7e0)
     libnsappshell.so + 0xf92c (0x4037392c)
     libnsappshell.so + 0x606a (0x4036a06a)
     GlobalWindowImpl::OpenInternal() 
     GlobalWindowImpl::OpenDialog() 
     WindowInternalOpenDialog() 
     js_Invoke()
     js_Interpret()
     js_Invoke() 
     libxpconnect.so + 0x1a9fb (0x407f29fb)
     libxpconnect.so + 0x19305 (0x407f1305) 
     PrepareAndDispatch() 
     nsXPTCStubBase::Stub5()
     XPTC_InvokeByIndex() 
     libxpconnect.so + 0x1e04e (0x407f604e)
     libxpconnect.so + 0x1f410 (0x407f7410)  
     js_Invoke() 
     js_Interpret()
     js_Invoke() 
     js_InternalInvoke() 
     JS_CallFunctionValue()
     nsJSContext::CallEventHandler() 
     nsJSEventListener::HandleEvent() 
     libgkcontent.so + 0x4dbb0 (0x40aa1bb0)
     libgkcontent.so + 0x4f68c (0x40aa368c) 
     libgkcontent.so + 0x129379 (0x40b7d379) 
     libgklayout.so + 0x632b6 (0x40d802b6) 
     libgklayout.so + 0x116761 (0x40e33761) 
     libgklayout.so + 0x1137bb (0x40e307bb)
     libgklayout.so + 0x631e2 (0x40d801e2) 
     libgklayout.so + 0x63002 (0x40d80002) 
     libgkview.so + 0x3989 (0x40f7f989) 
     libgkview.so + 0x392e (0x40f7f92e)
     libgkview.so + 0x392e (0x40f7f92e)
     libgkview.so + 0x392e (0x40f7f92e)
     libgkview.so + 0x127be (0x40f8e7be) 
     libgkview.so + 0x336d (0x40f7f36d)
     libwidget_gtk.so + 0x1a4ea (0x404a44ea) 
     libwidget_gtk.so + 0x1a415 (0x404a4415)
     libwidget_gtk.so + 0x1a570 (0x404a4570) 
     libwidget_gtk.so + 0x1b1bf (0x404a51bf)
     libwidget_gtk.so + 0x1ebaf (0x404a8baf) 
     libwidget_gtk.so + 0x15417 (0x4049f417) 
     libwidget_gtk.so + 0x1520e (0x4049f20e) 
     libgdk-1.2.so.0 + 0x174db (0x4060d4db) 
     libglib-1.2.so.0 + 0x10186 (0x4063a186)  
     libglib-1.2.so.0 + 0x10751 (0x4063a751) 
     libglib-1.2.so.0 + 0x108f1 (0x4063a8f1) 
     libgtk-1.2.so.0 + 0x8c5b9 (0x405625b9) 
     libwidget_gtk.so + 0xd35c (0x4049735c) 
     libnsappshell.so + 0xd3ca (0x403713ca) 
     main1()   
     main()
     libc.so.6 + 0x189cb (0x402439cb) 
(Reporter)

Comment 2

18 years ago
Need one more step to reproduce:
5. Click on OK button.

Comment 3

18 years ago
Is this a dup of bug 68208?

Comment 4

18 years ago
why is this assigned to asa? Shouldn't it be assigned to ftang? Xianglan, please
reassign as needed.
(Reporter)

Comment 5

18 years ago
Montse, this is not limited to changing the fonts for Western ISO-8859-1. For
any language, as long as you change the font for a different one, it crashes.

Comment 6

18 years ago
looks like a dup of 68208, it's crashes whenever you change the default pref
settings
(Assignee)

Comment 7

18 years ago

*** This bug has been marked as a duplicate of 68208 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 8

18 years ago
Verified dup.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.