Using keyboard to switch zoom level when viewing images directly

RESOLVED WONTFIX

Status

()

enhancement
RESOLVED WONTFIX
7 years ago
7 years ago

People

(Reporter: nicolas, Assigned: diogogmt)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (X11; Linux i686; rv:12.0a1) Gecko/20120103 Firefox/12.0a1
Build ID: 20120103031056

Steps to reproduce:

When an image is displayed directly in the browser and is larger than the view area, its size is adapted to the window. If you click on it, it becomes rendered in a 1:1 zoom level. If you click again, it comes back to the adapted zoom level.
This is impossible to do when navigating with the keyboard. Adding a shortcut (like the Spacebar) to switch between the two zoom levels could be useful.
(Reporter)

Updated

7 years ago
OS: Linux → All
Hardware: x86 → All
Seems reasonable. Good first bug?

Probably can't be space, though, since that's also used to scroll the page (and the page could be scrollable when viewed 1:1). At least, it would seem weird to do:

 * image loads, initially scaled to window
 * press space
 * image shown 1:1
 * press space
 ! image scrolls (eventually to bottom)
 * press space
 ! nothing happens (already at bottom)

Maybe Enter instead? Or change how Control +/- works?
I tested this out with the image located in the URL field of this bug.

Ctrl +/- already work to scale the image incrementally. If users would like a way to reach 1:1 scaling of the image, then I think we should add a modification to the normal Ctrl +/-, so maybe we could use shift-control +/-?

The other thing that this bug will have to do is to swap the cursor to use |cursor: -moz-zoom-out;| when the keyboard modifier is pressed.

The changes for this bug will probably occur in /content/html/document/src/ImageDocument.cpp.

Due to the lack of an XBL binding here, this is probably "good second bug" territory ;)
Severity: normal → enhancement
Status: UNCONFIRMED → NEW
Ever confirmed: true
Whiteboard: [good second bug][mentor=jwein][lang=c++][lang=css]
Version: 12 Branch → Trunk
Whiteboard: [good second bug][mentor=jwein][lang=c++][lang=css] → [mentor=jwein][lang=c++][lang=css]
Won't be able to do work on this one immediately as I'm working on some others but this one is definitely interesting to me. Going to take it for now.
Status: NEW → ASSIGNED
Assignee: nobody → schranz.m
Matthew: I've reassigned this bug to diogogmt since it sounds like they will be able to work on it sooner.
Assignee: schranz.m → diogo.gmt
Thats fine. I wasnt sure to take it in the beginning because it looked like diogo wanted it.
After speaking with Gavin, we decided that this feature is too hard for users to discover and its presence will only add complexity to the codebase.
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WONTFIX
Whiteboard: [mentor=jwein][lang=c++][lang=css]
You need to log in before you can comment on or make changes to this bug.