Last Comment Bug 715303 - No focus on select when tapping on selects
: No focus on select when tapping on selects
Status: VERIFIED FIXED
: testcase
Product: Firefox for Android
Classification: Client Software
Component: General (show other bugs)
: unspecified
: ARM Android
: P2 normal (vote)
: ---
Assigned To: Wesley Johnston (:wesj)
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-01-04 13:04 PST by Martijn Wargers [:mwargers] (not working for Mozilla)
Modified: 2012-01-31 08:13 PST (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed
fixed
11+


Attachments
testcase (696 bytes, text/html)
2012-01-04 13:04 PST, Martijn Wargers [:mwargers] (not working for Mozilla)
no flags Details
Patch (513 bytes, patch)
2012-01-05 12:26 PST, Wesley Johnston (:wesj)
mark.finkle: review+
akeybl: approval‑mozilla‑aurora+
Details | Diff | Review
testcase2 (1.59 KB, text/html)
2012-01-06 09:13 PST, Martijn Wargers [:mwargers] (not working for Mozilla)
no flags Details

Description Martijn Wargers [:mwargers] (not working for Mozilla) 2012-01-04 13:04:04 PST
Created attachment 585861 [details]
testcase

See testcase, when tapping on the selects, a focus event should fire.
This works fine in XUL Fennec and stock browser, but Fennec Native doesn't give focus to the select.
Comment 1 Wesley Johnston (:wesj) 2012-01-05 12:26:47 PST
Created attachment 586179 [details] [diff] [review]
Patch

Hmm... looks like we manually fired this in XUL Fennec right before sending a message to show the UI:

http://mxr.mozilla.org/mozilla-central/source/mobile/xul/chrome/content/forms.js#203

I'm only doing this for select elements for now here. The form assistant gets sent taps on all sorts of elements to determine if it needs to help, so we don't want to always call focus.
Comment 2 Martijn Wargers [:mwargers] (not working for Mozilla) 2012-01-06 09:13:45 PST
Created attachment 586457 [details]
testcase2

Sorry, I should have been more clear.
Not only, no focus events are fired, but I don't see any of the mouse events either.

See testcase, ideally, when tapping on the select, the same events as on the link should fire, namely:
mousemove
mousedown
focus
mouseup
click
And they also should fire in that order.
Comment 3 Wesley Johnston (:wesj) 2012-01-06 09:17:32 PST
I'll have to play a bit. We actually don't want clicks to fire on the select elements, as the selected item shouldn't change when you tap on multirow selects in mobile. But maybe there's some trickery we did before to fire click with some other target.
Comment 4 Martijn Wargers [:mwargers] (not working for Mozilla) 2012-01-06 09:22:50 PST
See the patch in bug 685197 for the trickery I used in XUL Fennec, especially the css part.
Comment 5 Wesley Johnston (:wesj) 2012-01-06 11:39:47 PST
filed bug 715990 for mouse events
https://hg.mozilla.org/integration/mozilla-inbound/rev/309fc0271e4c
Comment 6 Wesley Johnston (:wesj) 2012-01-10 12:56:06 PST
https://hg.mozilla.org/mozilla-central/rev/309fc0271e4c
Comment 7 Mark Finkle (:mfinkle) (use needinfo?) 2012-01-10 14:40:49 PST
Comment on attachment 586179 [details] [diff] [review]
Patch

[Approval Request Comment]
Caused by the new Native code. This fix gets Fennec back to XUL Fennec compat.
Comment 8 Alex Keybl [:akeybl] 2012-01-11 13:38:13 PST
Comment on attachment 586179 [details] [diff] [review]
Patch

[Triage Comment]
Mobile only - approved for Aurora.
Comment 9 Mark Finkle (:mfinkle) (use needinfo?) 2012-01-11 21:00:06 PST
https://hg.mozilla.org/releases/mozilla-aurora/rev/d265066b0aec
Comment 10 Cristian Nicolae (:xti) 2012-01-31 08:13:39 PST
Verified fixed on:

Mozilla/5.0 (Android;Linux armv7l;rv:11.0a2)Gecko/20120130
Firefox/11.0a2 Fennec/11.0a2
Device: Samsung Galaxy S
OS: Android 2.2

Mozilla/5.0 (Android;Linux armv7l;rv:12.0a1)Gecko/20120130
Firefox/12.0a1 Fennec/12.0a1
Device: Samsung Galaxy S
OS: Android 2.2

Note You need to log in before you can comment on or make changes to this bug.