Search panel should have horizontal scrollbar

RESOLVED DUPLICATE of bug 117612

Status

P4
normal
RESOLVED DUPLICATE of bug 117612
18 years ago
10 years ago

People

(Reporter: kazhik, Assigned: samir_bugzilla)

Tracking

(Blocks: 1 bug)

Trunk
Future
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Search panel in sidebar doesn't have horizontal scrollbar.

If you want to scroll vertically, you have to drag the splitter
to make vertical scrollbar shown.

Comment 1

17 years ago
reassign to samir
Assignee: matt → sgehani
Target Milestone: --- → mozilla0.9.6

Comment 2

17 years ago
Don't like adding a horizontal scroll bar since it will eat up UI space.  There
are 3 reasons to have a verticle scroll bar - why don't we address them in other
ways.

3 reasons:

1) to see the entire search button.  Possible way to fix that is to replace the
word "Search" with the same search icon that is used in the personal toolbar and
in the button next to the location bar.  I think we use the word Search enough
(in those places and as the name of the tab) to make the purpose of that button
clear.

2) the entire name of the engine you are "using".  Let's see if we can find a
way to limit the width of this baby.  If the sidebar is at its default width,
the "using XXXXX  \/ " should fit in that space - doesn't today.  Maybe we can
truncate it if necessary, or change the UI so the "using" is above the
selection, or ???

3) see more detail of an individual search result.  The best way to do this is
to use a tooltip like IE does - will never have enough room if we just make the
tab wider.

cc'ing Todd and German to see what they think.

Comment 3

17 years ago
These seem like good suggestions, I agree that at horizontal scroll is probably
unnecessary.  Changing the Search button to just an icon instead of text
probably won't fix it though, as the search engine text appears to be the
limiting factor.  Trying to have an appropriate default width here may be
challenging.  As for tooltips/titletips - definitely, those will be coming.  German?
(Assignee)

Updated

17 years ago
Priority: -- → P4
(Assignee)

Comment 4

17 years ago
Tooltips are almost there: bug 77624.  Maybe that solves the problem that lead
the reporter to file this bug?
(Assignee)

Updated

17 years ago
Target Milestone: mozilla0.9.6 → Future

Updated

16 years ago
Depends on: 172122

Updated

16 years ago
Blocks: 172122
No longer depends on: 172122
(Reporter)

Comment 5

16 years ago
The problem is search panel is too wide.

*** This bug has been marked as a duplicate of 117612 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.