WebFWD Affiliate buttons/banners

RESOLVED FIXED

Status

Marketing
Design
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: pfinette, Assigned: Rhonda Spencer)

Tracking

Details

Attachments

(4 attachments)

(Reporter)

Description

6 years ago
Created attachment 585901 [details]
WebFWD Logo (EPS)

We need a couple of IAB standard sized buttons/banners for WebFWD affiliates. Logo attached, potential text (happy to go with whatever you guys found effective in the past):

Accelerator for Open Web projects
Open Source project? Accelerate!
Mozilla's Open Innovation program
Working on Open Source? Apply now!

Thx!

Comment 1

6 years ago
Thanks Pascal.  Happy to help.  
Do you have any thoughts on timing for us?  when do you need these by? 
I don't have any stats on these phrases and what as worked best/better in the past.. do you have any preferences between these? 

Few quick thoughts, and cc-ing Matej to share his as well:

> Accelerator for Open Web projects
Sounds good but what is the CTA? seems a little incomplete to me.

Open Source project? Accelerate!
> Would "Accelerate" be the CTA here? what they'd sort of "click" on?

Mozilla's Open Innovation program
> Same comment as above, feel like it needs an actionable / clickable phrase.

Working on Open Source? Apply now!
> I guess this works too, though i wish it was clear what they were applying for...

These are all short phrases which is great for banners/promos.  But did you not want to mention WebFWD at all? would this just be communicated in the logo?  do you want to say "mozilla" here for context?

Assigning to Rhonda, hoping she can help crank these out once we figure out the above.
Assignee: tshahian → rspencer

Comment 2

6 years ago
I read these in pairs. Is that how they're supposed to work. If so, they look pretty good. Here are just some minor tweaks:

Accelerator for the Open Web
Open source project? Accelerate it!

Mozilla's Open Innovation Program
Working on open source? Apply now!
(Assignee)

Comment 3

6 years ago
Hi Tara--
Yes I can help. All I will need is any existing artwork, final sizes, and approved copy. Thanks!
--rhonda

Comment 4

6 years ago
Hehe, I totally didn't read them in pairs ;) thanks Matej.

Rhonda, sweet!  .ai file is attached to this bug, you're welcome to visit the WebFW website for more inspiration if needed.  Pascal - please approve copy, let us know deadline to handoff, and we'll get started.

Comment 5

6 years ago
Pascal, please let us know if you have issues with the copy, otherwise... Rhonda, copy is good to go.

I think Rhonda also needs some clarification on button sizes / specs.  Pascal if you can provide that that'd be great.
(Assignee)

Comment 6

6 years ago
Thanks Tara :)
Pascal, if I can get exact pixel dimensions of the banners you need (there are quite a few and it depends on where you are advertising them).

Also--the logo artwork I received was in black and white--is that what I should use or is there a color version somewhere?

And lastly--if there is an already existing URL that refers to this campaign, can someone send it to me so I can see what has been done creatively?

Thanks!
--rhonda

Comment 7

6 years ago
black and white!  :) please.  that's how it was designed.

Comment 8

6 years ago
aaand, the URL:  https://webfwd.org/
(Assignee)

Comment 9

6 years ago
OK thanks!
--rhonda
(Reporter)

Comment 10

6 years ago
My apologies for being so sluggish in responding to this bug.

So -- text looks great! Logo is indeed b/w and the site URL is (as Tara pointed out): https://webfwd.org.

In terms of sizes - It would be nice to have the following sizes:

300 x 250 IMU - (Medium Rectangle)
180 x 150 IMU - (Rectangle)
120 x 60 IMU - (Button 2)

Thank you!

Comment 11

6 years ago
Thanks Pascal

Could you please clarify what "IMU" means?  
and to confirm deliverables:  you're just looking for 3 flat graphics in the sizes you mentioned and PNG format?
(Reporter)

Comment 12

6 years ago
(In reply to Tara (musingt) from comment #11)

> Could you please clarify what "IMU" means?  

Internet Marketing Unit. A term the IAB coined. :)

> and to confirm deliverables:  you're just looking for 3 flat graphics in the
> sizes you mentioned and PNG format?

Yes, correct.

Thanks! :)
(Assignee)

Comment 13

6 years ago
Perfect. Thanks for the clarification all. :)
Coming right up.
--rhonda
(Assignee)

Comment 14

6 years ago
Hey Tara--
I put the WebFWD banner proofs in thier respective sized folders in my shared dropbox (I sent you an invite to join yesterday--let me know if you need me to resend). There are several versions of each, except for the smallest size because I thought that the "apply now" was the strongest CTA considering the space.

Take a look here:
Freshfruit Creative + Mozilla/WebFWD_banners

Thanks!
--rhonda
(Reporter)

Comment 15

6 years ago
Would you mind resending (best to my Dropbox email: pascal@finette.com)? Didn't seem to have it.

Thanks!
(Assignee)

Comment 16

6 years ago
Hi Pascal--
I just sent over.
:)--rhonda
(Assignee)

Comment 17

6 years ago
Created attachment 589669 [details]
180x150 WebFWD banner proof 1

Here are the banner proofs for review (they are also in my Dropbox)
(Assignee)

Comment 18

6 years ago
Created attachment 589670 [details]
120x60 WebFWD banner proof 1

Here are the banner proofs for review (they are also on my dropbox)
(Assignee)

Comment 19

6 years ago
Created attachment 589671 [details]
300x250 WebFWD banner proof 1

Here are the banner proofs for review (they are also on my dropbox)

Updated

6 years ago
Status: NEW → ASSIGNED

Comment 20

6 years ago
Thanks Rhonda.  Pascal do you have what you need? I think these are good overall.  Some are perhaps a little busier and therefore harder to read than others, but there are definitely some good options to choose from.

Comment 21

6 years ago
Closing out.  Thanks Rhonda !
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.