If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

checkboxes with "readonly" attribute are greyed out

ASSIGNED
Assigned to

Status

()

Core
Layout: Form Controls
ASSIGNED
6 years ago
4 years ago

People

(Reporter: Robert Rothenberg, Assigned: mounir)

Tracking

(Depends on: 1 bug)

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:9.0) Gecko/20100101 Firefox/9.0 Iceweasel/9.0
Build ID: 20111220194651

Steps to reproduce:

Specified a checkbox as 

  <input id="role_id0" type="checkbox" checked="checked"  readonly="readonly" value="0" name="role" />


Actual results:

Checkbox displayed as greyed out (presumably readonly), but it can still be unchecked when one clicks on it.


Expected results:

Checkbox should not alow one to change state.
Seems to me that the spec says we should ignore readonly on checkboxes.
Component: Untriaged → Layout: Form Controls
Product: Firefox → Core
QA Contact: untriaged → layout.form-controls

Updated

6 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 88512
I think the fact that the checkbox is greyed out is a bug, though.
Status: RESOLVED → REOPENED
Ever confirmed: true
Resolution: DUPLICATE → ---
Summary: Readonly checkboxes are not readonly → checkboxes with "readonly" attribute are greyed out
(Assignee)

Comment 4

6 years ago
(In reply to Ms2ger from comment #3)
> I think the fact that the checkbox is greyed out is a bug, though.

Indeed.
OS: Linux → All
Hardware: x86_64 → All
Version: 9 Branch → Trunk
(Assignee)

Comment 5

6 years ago
So I have a patch that should fix that but it's assuming <input type='checkbox'> has :read-write applying instead of :read-only. I'm going to attach it here but I will wait to see how bug 715484 evolves before requesting a review.
Depends on: 715484
(Assignee)

Comment 6

6 years ago
Created attachment 586060 [details] [diff] [review]
WIP Patch

I could probably add a test for disabled states too.
Assignee: nobody → mounir
Status: REOPENED → ASSIGNED
You need to log in before you can comment on or make changes to this bug.