Firefox 9 eats all my ram and crashes with Tab Mix Plus

RESOLVED WORKSFORME

Status

()

Firefox
Extension Compatibility
--
critical
RESOLVED WORKSFORME
6 years ago
6 years ago

People

(Reporter: g.schlisio, Unassigned)

Tracking

({crash})

9 Branch
x86_64
Linux
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:9.0.1) Gecko/20100101 Firefox/9.0.1
Build ID: 20111222095143

Steps to reproduce:

This issue is not related to special website.
I use FF 9.01 with tab mix plus with about 80 tabs open at a time.
sometimes, ff begins to consume all cpu on one core and ram usage is rising (not cached data, but application data). usually i kill ff before my ram is filled totally, but if not, it just crashes.
i think this may be related to a (paused?) flash player in some tabs, but not sure about that. flashplayer version is 11.1 r102, i use a x86_64 linux system.
(sorry about that very unspecific report, what can i do to find out more on the issue?)


Actual results:

ram filled, ff crashed


Expected results:

no crash, of course. just work like a charm like was before

Comment 1

6 years ago
You should at least test to see if it occurs in Safe Mode, to see if it's caused by an add-on.

http://support.mozilla.org/en-US/kb/Safe%20Mode

Comment 2

6 years ago
about:memory may tell you where the memory has gone.

Updated

6 years ago
Severity: normal → critical
Keywords: crash
OS: Other → Linux
Hardware: Other → x86_64
(Reporter)

Comment 3

6 years ago
ok, because its just not possible to work without addons with such an amount of tabs, i'll monitor memory usage with about:memory.
thanks fol all help and sugesstions!
(Reporter)

Comment 4

6 years ago
ok, the tab with url
http://www.cbsnews.com/8301-31727_162-57338546-10391695/documents-atf-used-fast-and-furious-to-make-the-case-for-gun-regulations/
opend increasingly ate memory labeled under js. this time, memory consumption was far slower than the bug report reasons, do maybe not related. anyway, over time it was eating over 500mb.

Comment 5

6 years ago
Does the page do it when you leave it idle alone, or do you browse there and click on other stories?
(Reporter)

Comment 6

6 years ago
indeed, the notebook was running idle then. any known issues with that?

Updated

6 years ago
Component: Untriaged → Extension Compatibility
QA Contact: untriaged → extension.compatibility
Summary: Firefox 9 eats all my ram and crashes → Firefox 9 eats all my ram and crashes with Tab Mix Plus

Comment 7

6 years ago
I have left that page open for some hours and its compartment is still at 12MB (quite low considering it pulls scripts from about 20 3rd party servers). In FF12 with no extensions it sits at 7MB.
(Reporter)

Comment 8

6 years ago
ok, i was not able to reproduce bug again since reported. shall we close this?
i'm very sorry this didnt work out.
Component: Extension Compatibility → Untriaged

Updated

6 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Component: Untriaged → Extension Compatibility
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.