Message filtering by "Delivered-To" header fails if there are multiple "Delivered-To" occurrences.

RESOLVED DUPLICATE of bug 678322

Status

MailNews Core
Filters
RESOLVED DUPLICATE of bug 678322
6 years ago
3 years ago

People

(Reporter: Jan, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; rv:5.0.1) Gecko/20100101 Firefox/5.0.1
Build ID: 20111230031151

Steps to reproduce:

I am trying to filter incoming mail by the "Delivered-To" header. The mails contain two "Delivered-To" headers – one being my individual mail address and one being the mailing list address it was originally composed to (BCC).

I created a custom field Delivered-To and set up a filter to move the messages to a sub-directory.


Actual results:

Filtering works for the first "Delivered-To" header, but not the second one.


Expected results:

The message filter should look at all headers and not just the first occurrence.
(Reporter)

Updated

6 years ago
OS: Windows 7 → Mac OS X
is it and or or and and close in your filter ?
Component: General → Filters
Product: Thunderbird → MailNews Core
QA Contact: general → filters
(Reporter)

Comment 2

6 years ago
I originally had two filters applied — but tested it with only one rule now. No difference (hence no difference with either AND or OR). The Delivered-To rule is set to "contains".

Comment 3

5 years ago
I've had other requests for this wrt FiltaQuilla. Looking at the core code at http://hg.mozilla.org/comm-central/diff/7b75008cb771/mailnews/base/search/src/nsMsgSearchTerm.cpp we do accumulation for the received header, but not for delivered-to. So this is a legitimate request. The core change would not be very difficult - though not sure if there are any negative ramifications of doing this.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

5 years ago
OS: Mac OS X → All
Hardware: x86 → All
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 678322
You need to log in before you can comment on or make changes to this bug.