Last Comment Bug 715576 - libalerts_s.dylib incorrectly links the static version of spidermonkey (in static-js configuration)
: libalerts_s.dylib incorrectly links the static version of spidermonkey (in st...
Status: RESOLVED FIXED
[not-fennec-11]
:
Product: Core
Classification: Components
Component: Build Config (show other bugs)
: unspecified
: x86_64 Mac OS X
: -- normal (vote)
: mozilla12
Assigned To: Benjamin Smedberg [:bsmedberg]
:
Mentors:
Depends on:
Blocks: 717376
  Show dependency treegraph
 
Reported: 2012-01-05 10:56 PST by Benjamin Smedberg [:bsmedberg]
Modified: 2012-02-06 16:16 PST (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Fix libalerts naming and JS linkage, rev. 1 (5.39 KB, patch)
2012-01-06 09:32 PST, Benjamin Smedberg [:bsmedberg]
ted: review+
Details | Diff | Splinter Review

Description Benjamin Smedberg [:bsmedberg] 2012-01-05 10:56:32 PST
libalerts_s.dylib is linking against the static version of spidermonkey (in the static-js configuration which is default on non-Windows) because it is using MOZ_JS_LIBS. I can't figure out why it needed to do this in the past (or whether this is just a copy/paste bug), but I'm going to fix it.
Comment 1 Benjamin Smedberg [:bsmedberg] 2012-01-06 09:32:06 PST
Created attachment 586458 [details] [diff] [review]
Fix libalerts naming and JS linkage, rev. 1
Comment 2 Benjamin Smedberg [:bsmedberg] 2012-01-11 09:25:46 PST
https://hg.mozilla.org/mozilla-central/rev/17a76e33b6fe

Note You need to log in before you can comment on or make changes to this bug.