Logging in does not follow original request

VERIFIED DUPLICATE of bug 810992

Status

Participation Infrastructure
Phonebook
P2
normal
VERIFIED DUPLICATE of bug 810992
7 years ago
5 years ago

People

(Reporter: jdm, Unassigned)

Tracking

({regression})

Details

(Whiteboard: [regression])

(Reporter)

Description

7 years ago
If I visit a link to mozillians.org and I am not logged in, I would expect that I would be taken to the original link upon logging in. Instead, I am always redirected to my profile.
This sounds like
SUSPENSE.
This sounds like a user complaint on the 6-hour session cookie we've had on mozillians for awhile.
(Reporter)

Comment 4

7 years ago
I don't see the connection. This occurs when I visit a link, get redirected to the login page, login immediately, and then am taken to my profile.
(Reporter)

Comment 5

7 years ago
From digging through the code, I'm pretty sure this was a regression introduced along with BrowserID, but I couldn't find the place where the actual redirect occurs upon successful login.
(Reporter)

Comment 6

7 years ago
Aha, the culprit is at https://github.com/mozilla/mozillians/blob/master/apps/browserid/views.py#L41 . This was introduced with BrowserID; previously we were presumably using the default django auth stuff that tied in with django.contrib.auth.redirect_to_login, which has some magic that redirects to the given next URL on successfully logging in.
Ah, I see what the issue is. Thanks for flagging down the issue. Interested in offering a commit, Josh?
Keywords: regression
Priority: -- → P2
Target Milestone: --- → 1.3
(Reporter)

Comment 8

7 years ago
Ordinarily yes, but there's enough uncertainty in my understanding that I'll leave it to someone more experienced.

Updated

6 years ago
OS: Mac OS X → All
Hardware: x86 → All
Whiteboard: [regression]
Duplicate of this bug: 740938

Updated

6 years ago
Component: mozillians.org → Phonebook
Product: Websites → Community Tools
QA Contact: mozillians-org → phonebook
Target Milestone: 1.3 → ---
Version: unspecified → other

Updated

6 years ago
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 810992
Bumping to QA verified duplicate.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.