[RFE] chatzilla add support for socks proxy

RESOLVED FIXED

Status

Other Applications
ChatZilla
--
enhancement
RESOLVED FIXED
17 years ago
14 years ago

People

(Reporter: Gael Le Mignot, Assigned: bbaetz)

Tracking

Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.4.1 i686; en-US; 0.8) Gecko/20010215
BuildID:    Any

Could you add support for SOCKS5 proxy with authentification in chatzilla?
Thank you

Reproducible: Always
Steps to Reproduce:
Try to connect behing a firewall with a socks5 proxy

Actual Results:  [INFO] Connecting...
<infinite loop>

Expected Results:  A connection

Updated

17 years ago
Keywords: helpwanted, qawanted
Whiteboard: DUPEME

Comment 1

17 years ago
Can't find dupe so marking NEW.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: qawanted
OS: Linux → All
Hardware: PC → All
Summary: [chatzilla] add support for socks proxy → [RFE] add support for socks proxy
Whiteboard: DUPEME

Comment 2

17 years ago
Changing title as per request of reporter.
Summary: [RFE] add support for socks proxy → [RFE] chatzilla add support for socks proxy
(Assignee)

Comment 3

17 years ago
This will be < 10 lines of code with my fixes to 89500. Taking.

Note that our socks proxy support doesn't support authentication - there's a
separate bug on that. When it does, (and this bug is fixed) chatzilla should
automatically support it too.
Assignee: rginda → bbaetz
Depends on: 89500
(Assignee)

Comment 4

17 years ago
This got fixed with the patch for 89500. I'm going to close this out, even
though that patch will end up on the branch, since this specific patch isn't
nsBranch material.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Keywords: helpwanted
Resolution: --- → FIXED
Whiteboard: fixed-on-trunk

Comment 5

16 years ago
It doesn't work for me. I tried Mozilla 0.9.2 - 0.9.7 and current nightly,
but it doesn't work. I've set web proxy and socks proxy for SOCKS 5.
The same operation (same socks server) works for other IRC client,
also AIM and MSN messenger.

Is it proxy server problem?

Comment 6

16 years ago
reopening because it doesn't seem to work
Status: RESOLVED → REOPENED
QA Contact: mozilla → samuel
Resolution: FIXED → ---
Whiteboard: fixed-on-trunk
(Assignee)

Comment 7

16 years ago
Patch on bug 109600
Depends on: 109600
(Assignee)

Comment 8

16 years ago
regression fixed. This probably came out of one of darin's cleanups.
Status: REOPENED → RESOLVED
Last Resolved: 17 years ago16 years ago
Resolution: --- → FIXED
Product: Core → Other Applications
You need to log in before you can comment on or make changes to this bug.