Last Comment Bug 715720 - [Azure] Support DrawTarget in CanvasLayerOGL
: [Azure] Support DrawTarget in CanvasLayerOGL
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Graphics (show other bugs)
: unspecified
: x86 Mac OS X
: -- normal (vote)
: mozilla12
Assigned To: Matt Woodrow (:mattwoodrow)
:
Mentors:
Depends on:
Blocks: 687187
  Show dependency treegraph
 
Reported: 2012-01-05 16:25 PST by Matt Woodrow (:mattwoodrow)
Modified: 2012-01-16 19:56 PST (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
DrawTarget support (1.52 KB, patch)
2012-01-05 16:25 PST, Matt Woodrow (:mattwoodrow)
jmuizelaar: review+
Details | Diff | Review

Description Matt Woodrow (:mattwoodrow) 2012-01-05 16:25:07 PST
Created attachment 586270 [details] [diff] [review]
DrawTarget support

Allow CanvasLayerOGL delayed updates path to recognize and use a DrawTarget as well as gfxASurface
Comment 1 Jeff Muizelaar [:jrmuizel] 2012-01-06 13:05:24 PST
What is this needed for?
Comment 2 Matt Woodrow (:mattwoodrow) 2012-01-06 13:10:07 PST
It crashes if it tries to take this path (because of a large canvas) when Azure is enabled.
Comment 3 Jeff Muizelaar [:jrmuizel] 2012-01-06 14:05:28 PST
Comment on attachment 586270 [details] [diff] [review]
DrawTarget support

I still don't quite understand but ok.
Comment 4 Matt Woodrow (:mattwoodrow) 2012-01-16 13:58:17 PST
https://hg.mozilla.org/integration/mozilla-inbound/rev/97deecdd51f1
Comment 5 Justin Wood (:Callek) 2012-01-16 19:56:12 PST
https://hg.mozilla.org/mozilla-central/rev/97deecdd51f1

Note You need to log in before you can comment on or make changes to this bug.