Workers: Enable TI and allow JIT hardening to be disabled

RESOLVED FIXED

Status

()

Core
DOM
RESOLVED FIXED
6 years ago
5 years ago

People

(Reporter: Ben Turner (not reading bugmail, use the needinfo flag!), Assigned: Ben Turner (not reading bugmail, use the needinfo flag!))

Tracking

11 Branch
Points:
---

Firefox Tracking Flags

(firefox9 affected, firefox10- affected, firefox11- affected, firefox12 fixed)

Details

(Whiteboard: [qa-])

Attachments

(1 attachment)

Created attachment 586295 [details] [diff] [review]
Patch, v1

Looks like we forgot to enable TI on workers when it landed. Also this JIT hardening thing should be exposed too.
Attachment #586295 - Flags: review?(jonas)
Assignee: nobody → bent.mozilla
Status: NEW → ASSIGNED
Attachment #586295 - Flags: review?(jonas) → review+
https://hg.mozilla.org/mozilla-central/rev/8b0437df0da3
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
status-firefox10: --- → affected
status-firefox11: --- → affected
status-firefox12: --- → fixed
status-firefox9: --- → affected
tracking-firefox10: --- → ?
tracking-firefox11: --- → ?
Comment on attachment 586295 [details] [diff] [review]
Patch, v1

[Approval Request Comment]
Regression caused by (bug #): 
Not really a regression

User impact if declined: 
Workers will be slower than main thread.

Testing completed (on m-c, etc.): 
Tons of mochitests.

Risk to taking this patch (and alternatives if risky):
Almost none. TI is stable now, and this patch is very simple.
Attachment #586295 - Flags: approval-mozilla-beta?
Attachment #586295 - Flags: approval-mozilla-aurora?

Comment 3

6 years ago
Comment on attachment 586295 [details] [diff] [review]
Patch, v1

[Triage Comment]
I want to keep this in the queue for discussion at Tuesday's channel meeting.

Updated

6 years ago
tracking-firefox10: ? → -
tracking-firefox11: ? → -
Keywords: #relman/triage/defer-to-group

Comment 4

5 years ago
Comment on attachment 586295 [details] [diff] [review]
Patch, v1

[Triage Comment]
We're concerned with the possibility of an unexpected interaction between TI and workers. Given the fact that this appears to only have a user-impact related to performance, we'll let this ride the train.
Attachment #586295 - Flags: approval-mozilla-beta?
Attachment #586295 - Flags: approval-mozilla-beta-
Attachment #586295 - Flags: approval-mozilla-aurora?
Attachment #586295 - Flags: approval-mozilla-aurora-
Whiteboard: [qa-]
You need to log in before you can comment on or make changes to this bug.