Sort by junk status malfunctioning

RESOLVED WORKSFORME

Status

Thunderbird
General
RESOLVED WORKSFORME
7 years ago
6 years ago

People

(Reporter: Florent Angly, Unassigned)

Tracking

9 Branch
x86_64
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:9.0.1) Gecko/20100101 Firefox/9.0.1
Build ID: 20111220165912

Steps to reproduce:

Steps to Reproduce:
1. Open thunderbird (9.0.1 on Linux 64 bit system)
2. Go in my [Gmail] > Spam folder
3. Click on the 'sort by junk status' header icon on the message list


Actual Results:  
Nothing, message list maintained its previous order

Expected Results:  
Display first the messages that are junk and then the normal ones, like Mozilla
MailNews does


Actual results:

The emails are  reorganized, with emails marked as spam and unmarked emails intersperesed.


Expected results:

Emails marked as spam and unmarked emails should be sorted and not interspersed.
(Reporter)

Comment 1

7 years ago
Actually, I notice that this problem happens only when marking on unmarking emails as junk before sorting.

Steps to Reproduce:
1. Open thunderbird (9.0.1 on Linux 64 bit system)
2. Go in my [Gmail] > Spam folder
3. Mark or unmark some emails as junk
4. Click on the 'sort by junk status' header icon on the message list
> intersperesed 

What are you trying to say with that word ?

This works for me on trunk.

Does it happens also in safe-mode (see http://support.mozillamessaging.com/en-US/kb/Safe-Mode#os=mac&browser=tb7) ?

Comment 3

6 years ago
Reporter not replying
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → INCOMPLETE
(Reporter)

Comment 4

6 years ago
Sorry Ludovic, I did not notice your reply.
I checked again, and sorting by junk status seems to work again for me. I am still using the same Thunderbird version, so I am not sure why.

Comment 5

6 years ago
no problem. thanks for the update
Resolution: INCOMPLETE → WORKSFORME
You need to log in before you can comment on or make changes to this bug.