Intermittent dom/workers/test/test_recursion.html | application crashed [@ mozilla::dom::workers::WorkerPrivate::DispatchToSyncQueue(mozilla::dom::workers::WorkerSyncRunnable*)]

RESOLVED WORKSFORME

Status

()

Core
DOM: Workers
--
critical
RESOLVED WORKSFORME
7 years ago
4 years ago

People

(Reporter: philor, Unassigned)

Tracking

({crash, intermittent-failure})

Trunk
x86
Mac OS X
crash, intermittent-failure
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

7 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=8368137&tree=Mozilla-Inbound
Rev4 MacOSX Snow Leopard 10.6 mozilla-inbound debug test mochitests-3/5 on 2012-01-05 21:37:24 PST for push 8dc46cdc401b

TEST-UNEXPECTED-FAIL | /tests/dom/workers/test/test_recursion.html | Exited with code 1 during test run
INFO | automation.py | Application ran for: 0:10:52.010494
INFO | automation.py | Reading PID log: /var/folders/Hs/HsDn6a9SG8idoIya6p9mtE+++TI/-Tmp-/tmpRossAbpidlog
PROCESS-CRASH | /tests/dom/workers/test/test_recursion.html | application crashed (minidump found)
Crash dump filename: /var/folders/Hs/HsDn6a9SG8idoIya6p9mtE+++TI/-Tmp-/tmpArBIo3/minidumps/D925B398-F1EB-437F-8D0F-2BB271ADCFE1.dmp
Operating system: Mac OS X
                  10.6.8 10K549
CPU: amd64
     family 6 model 23 stepping 10
     2 CPUs

Crash reason:  EXC_BAD_ACCESS / 0x0000000d
Crash address: 0x0

Thread 0 (crashed)
 0  XUL!mozilla::dom::workers::WorkerPrivate::DispatchToSyncQueue [Queue.h:8dc46cdc401b : 192 + 0x3]
    rbx = 0x4d63d968   r12 = 0x4ab6c650   r13 = 0x2459dc00   r14 = 0x4baf7180
    r15 = 0x2459dc10   rip = 0x025a255e   rsp = 0x5fbfc6d0   rbp = 0x5fbfc710
    Found by: given as instruction pointer in context
 1  XUL!mozilla::dom::workers::WorkerSyncRunnable::DispatchInternal [WorkerPrivate.h:8dc46cdc401b : 585 + 0xa]
    rbx = 0x00000000   r12 = 0x4ab6c650   r13 = 0x00000000   r14 = 0x4baf7180
    r15 = 0x2459dc00   rip = 0x025a29e8   rsp = 0x5fbfc720   rbp = 0x5fbfc720
    Found by: call frame info
 2  XUL!mozilla::dom::workers::WorkerRunnable::Dispatch [WorkerPrivate.cpp:8dc46cdc401b : 1543 + 0x9]
    rbx = 0x00000000   r12 = 0x4ab6c650   r13 = 0x00000000   r14 = 0x4baf7180
    r15 = 0x2459dc00   rip = 0x0259ee24   rsp = 0x5fbfc730   rbp = 0x5fbfc7d0
    Found by: call frame info
 3  XUL!WorkerThreadProxySyncRunnable::Run [XMLHttpRequestPrivate.cpp:8dc46cdc401b : 797 + 0x9]
    rbx = 0x4ab6c650   r12 = 0x0000003e   r13 = 0x4d1c5120   r14 = 0x4baf7180
    r15 = 0x2459dc00   rip = 0x025bcafa   rsp = 0x5fbfc7e0   rbp = 0x5fbfc830
    Found by: call frame info
 4  XUL!nsThread::ProcessNextEvent [nsThread.cpp:8dc46cdc401b : 660 + 0x5]
    rbx = 0x00000000   r12 = 0x00000000   r13 = 0x0510c8d0   r14 = 0x00000000
    r15 = 0x0510c910   rip = 0x0345f68c   rsp = 0x5fbfc840   rbp = 0x5fbfc900
    Found by: call frame info
 5  XUL!NS_ProcessPendingEvents_P [nsThreadUtils.cpp:8dc46cdc401b : 195 + 0xd]
    rbx = 0x0510c8d0   r12 = 0x00000000   r13 = 0xb1905c5d   r14 = 0x00000014
    r15 = 0x5fbfc91f   rip = 0x033e8a7e   rsp = 0x5fbfc910   rbp = 0x5fbfc950
    Found by: call frame info
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)

Updated

6 years ago
Crash Signature: [@ mozilla::dom::workers::WorkerPrivate::DispatchToSyncQueue]
Keywords: crash
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Component: DOM → DOM: Workers
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
(Assignee)

Updated

6 years ago
Keywords: intermittent-failure

Updated

6 years ago
Duplicate of this bug: 814542
(Assignee)

Updated

6 years ago
Whiteboard: [orange]
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)

Updated

5 years ago
Summary: Intermittent crash [@ mozilla::dom::workers::WorkerPrivate::DispatchToSyncQueue] in dom/workers/test/test_recursion.html → Intermittent dom/workers/test/test_recursion.html | application crashed [@ mozilla::dom::workers::WorkerPrivate::DispatchToSyncQueue(mozilla::dom::workers::WorkerSyncRunnable*)]
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)

Updated

5 years ago
Duplicate of this bug: 897447
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Closing bugs where TBPLbot has previously commented, but have now not been modified for >3 months & do not contain the whiteboard strings for disabled/annotated tests or use the keyword leave-open. Filter on: mass-intermittent-bug-closure-2014-07
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.