Last Comment Bug 715852 - JS Test Failure on ecma_5/Object/proto-property-change-writability-set.js ( Assertion failure: shape->writable() )
: JS Test Failure on ecma_5/Object/proto-property-change-writability-set.js ( A...
Status: RESOLVED FIXED
js-triage-done
: assertion, regression, testcase
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: Trunk
: All All
: -- critical (vote)
: mozilla12
Assigned To: Jeff Walden [:Waldo] (remove +bmo to email)
:
: Jason Orendorff [:jorendorff]
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-01-06 03:49 PST by Christian Holler (:decoder)
Modified: 2012-01-07 19:32 PST (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Christian Holler (:decoder) 2012-01-06 03:49:22 PST
The JS test mentioned in the subject has been failing for a while now, with:

Assertion failure: shape->writable(), at js/src/methodjit/StubCalls.cpp:170

Tested with m-c revision 8ae16e346bd0.
Comment 1 Jeff Walden [:Waldo] (remove +bmo to email) 2012-01-06 23:01:26 PST
Er, I fail at life.  Did I really fix the interpreter code but not the stubcall code?  Looks like it.  Such a rookie error.

https://hg.mozilla.org/integration/mozilla-inbound/rev/985b197bb232
Comment 2 Ed Morley [:emorley] 2012-01-07 19:32:18 PST
https://hg.mozilla.org/mozilla-central/rev/985b197bb232

Note You need to log in before you can comment on or make changes to this bug.