Closed Bug 715856 Opened 9 years ago Closed 8 years ago

[10.7] Trying to leave Mibbit site with 2 finger swipe succeeds prematurely, and causes a modal dialog "hang"

Categories

(Core :: General, defect)

9 Branch
All
macOS
defect
Not set
critical

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox9 - affected
firefox10 - affected
firefox11 - affected
firefox12 - affected

People

(Reporter: whimboo, Unassigned)

References

(Blocks 2 open bugs)

Details

(Keywords: hang, regression, testcase, Whiteboard: [qa+])

Attachments

(1 file)

Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:11.0a2) Gecko/20111229 Firefox/11.0a2 ID:20111229042021

If the user has configured Firefox to use the 2 finger swipe to navigate back and forward, the browser will completely hang due to the modal alert. Steps to reproduce are really simple:

Steps:
1. Open https://wiki.mozilla.org/QA/Automation_Services/Team
2. Click on one of the IRC links and use Mibbit to connect to IRC
3. Wait until Mibbit has been loaded and swipe with 2 fingers to the left
4. Try to close the modal alert

We will not be successful with step 4. Actually the browser has been frozen and needs to be force killed.

I can reproduce it back to Firefox 9 for now. Earlier versions somehow don't react on the two finger swipe and don't show this behavior.

Could that be related to the new implementation which initially went into Firefox 9 by bug 668953?
Not sure but it could be that I hit bug 715829 due to this bad behavior.
Would be great if someone could test Firefox 9 on 10.6 if there is the same issue or not.
Summary: Trying to leave Mibbit site with 2 finger swipe completely hangs Firefox → Trying to leave Mibbit site with 2 finger swipe causes a modal dialog which completely freezes Firefox
Version: Trunk → 9 Branch
This issue doesn't occur when you close the tab, or click onto the back button. So it seems like we have an issue with the event loop?
Also this only happens for me when 'Swipe between full-screen apps' is disabled in the trackpad / mouse system settings.
As talked with Virgil on IRC this is not reproducible in 10.6 and that's why related to the two finger swipe implementation in 10.7.
Component: Widget: Cocoa → General
Depends on: 668953
QA Contact: cocoa → general
Summary: Trying to leave Mibbit site with 2 finger swipe causes a modal dialog which completely freezes Firefox → [10.7] Trying to leave Mibbit site with 2 finger swipe causes a modal dialog which completely freezes Firefox
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:11.0a2) Gecko/20120105 Firefox/11.0a2

Used whimboo's steps from comment 0.

CAN reproduce with any of the following settings for "swipe between pages":
-"swipe left or right with one finger"
-"swipe with one or two fingers"

CAN'T reproduce with the following setting for "swipe between pages":
-"swipe left or right with two fingers"
Keywords: hang
I can reproduce this with default System Preferences settings
(including with "Swipe between pages" set to "Scroll left or right
with two fingers").

The "hang" is bug 476541, which for complicated reasons isn't going to
get fixed anytime soon.  For more information see bug 691702 comment
#8 and bug 691702 comment #9.

But the actual bug is that two-finger swipes, as currently
implemented, can take place even when "blocked" by a modal dialog.
This shouldn't be too hard to fix.  That's what	I'll be	doing.
Component: General → Widget: Cocoa
QA Contact: general → cocoa
Assignee: nobody → smichaud
Status: NEW → ASSIGNED
Summary: [10.7] Trying to leave Mibbit site with 2 finger swipe causes a modal dialog which completely freezes Firefox → [10.7] Trying to leave Mibbit site with 2 finger swipe succeeds prematurely, and causes a modal dialog "hang"
(In reply to Steven Michaud from comment #7)
> The "hang" is bug 476541, which for complicated reasons isn't going to
> get fixed anytime soon.  For more information see bug 691702 comment
> #8 and bug 691702 comment #9.

Huh, why is that bug 476541? There is no other modal dialog open. It's really just the dialog from Mibbit.

Also this is a regression not from the original implementation of the 2 finger swipe. Working on the regression range right now. Currently it happened between 111001 and 111007.

> But the actual bug is that two-finger swipes, as currently
> implemented, can take place even when "blocked" by a modal dialog.
> This shouldn't be too hard to fix.  That's what	I'll be	doing.

I still think the hang is different and needs to be fixed too.
Component: Widget: Cocoa → General
> Also this is a regression not from the original implementation of
> the 2 finger swipe. Working on the regression range right
> now. Currently it happened between 111001 and 111007.

I'll await your results, and see if I can reproduce them.
I can reproduce your regression range, Henrik.

But my results with the 2011-10-04 mozilla-central nightly are different from my results with today's mozilla-central nightly.  Both "hang" (unlike the 2011-10-03 nightly).  But today's nightly also swipes back to the previous page even while the modal dialog is still up that asks if the user wants to leave the current page.

This behavior starts with the 2011-10-06 mozilla-central nightly (and isn't present in the 2011-10-05 nightly).

It's probably unrelated, but I'm going to find out which patch triggered this.
Ok, so the hang is visible since the back-out for bug 622315 happened. Looks like that with the implementation of the two-finger swipe and the patch for bug 622315 we don't see this hang, but it would probably manifest itself once we back-out it locally for earlier builds until the changeset for the two-finger swipe implementation on bug 668953.

So not sure I can do more on the regression test front. More helpful would probably be a minimized testcase here.
The patch for bug 622315 basically said, "You may not navigate while a navigation is pending."  So we're probably getting confused somehow here.
Attached file testcase (zip archive)
Minimized testcase from Mibbit. Sadly I cannot strip down the remaining JS code because stuff is getting dynamically created.
Steven, do you have any update regarding the tests you wanted to do?
Right now I'm working on bug 715885, which is a topcrasher and seems more urgent.  I should be able to get back to this bug later this week.
[Triage Comment]
Not enough volume of reports to warrant tracking. We would, however, consider uplifting if a low-risk patch is landed on m-c.
Henrik, can you still reproduce this?
No, I can't with the latest version of Aurora. Some landed patch might have fixed that. Closing as WFM.
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → WORKSFORME
Assignee: smichaud → nobody
You need to log in before you can comment on or make changes to this bug.