18 tabs with dark grey background (originally: Long tab list leaves Win 7 system tray and clock overpainted -> equal to bug 610713)

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
7 years ago
5 years ago

People

(Reporter: s-computer, Unassigned)

Tracking

9 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
Created attachment 586407 [details]
Screenshots

To reproduce:
I opened the list of tabs with the triangle in the top right corner and it expands down over the system tray and clock. (currently about 130 tabs open)

Actual Results:
No matter whether the FF window is maximized or not, the menu leaves the system tray and clock overpainted, if you don't close the tab list by clicking on the triangle again, e.g. by clicking on one list item or back into the browser. 
Sometimes even closing with the triangle won't help and in rare cases, the desktop or other programs stay overpainted as well. 

The only way to get the window(s) and tray right again is forcing a repaint event, for example by triggering an icon animation or moving an "always on top" window like the taskmanager over those overpainted parts.

Another weird thing is that there are 18 tabs "marked" with a dark grey background, whereas all other tabs have the normal grey. The coloring works as follows:
The top item of this "selection" is the last created tab or the last tab jumped to, if the old selection didn't already contain this tab and it is possible to have 18 dark items starting with it. (even with about 20 tabs more, the number stays 18.)

My system is completely updated, but Aero Peek is deactivated since OS installation.

Expected:
No graphical remainders of menues on the taskbar or any other programs and no weird dark grey "selection", if the latter was not designed to be this way.

Comment 1

7 years ago
Pretty sure this is bug 610713
Whiteboard: DUPME
(Reporter)

Updated

7 years ago
Summary: Long tab list leaves Win 7 system tray and clock overpainted → 18 tabs with dark grey background (originally: Long tab list leaves Win 7 system tray and clock overpainted -> equal to bug 610713)
(Reporter)

Comment 2

7 years ago
You're right. The first part of my description is most probably the bug 610713. I thought the 18 dark grey tabs were part of the same bug, but such a thing is never mentioned in 610713. Therefore I changed the title of this bug accordingly.

(If you wish to change the title into something else, just mention it here.)
s-computer, does this still happen for you ? I can't reproduce it.
Flags: needinfo?(s-computer)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INCOMPLETE
(Reporter)

Comment 4

5 years ago
I tested it again on my computer with the Windows 7-Basis, Windows 7 (Aero), Windows Classic and a custom Design: the artefacts definitely do not appear anymore in combination with FF 23.0.1 (release) and both Aero Peek enabled or disabled.

FYI: I'm installing Windows 8, so I won't be able to test it with other versions, but the above should be sufficient.
Flags: needinfo?(s-computer)
Resolution: INCOMPLETE → WORKSFORME
Whiteboard: DUPME
You need to log in before you can comment on or make changes to this bug.