Last Comment Bug 715882 - Tooltip(title attibute of the element) pops up even if the element has been removed.
: Tooltip(title attibute of the element) pops up even if the element has been r...
Status: RESOLVED FIXED
: regression
Product: Core
Classification: Components
Component: DOM (show other bugs)
: Trunk
: x86 All
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
: Andrew Overholt [:overholt]
Mentors:
Depends on:
Blocks: 664058
  Show dependency treegraph
 
Reported: 2012-01-06 06:49 PST by Alice0775 White
Modified: 2012-01-22 23:55 PST (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
testcase (171 bytes, text/html)
2012-01-06 06:49 PST, Alice0775 White
no flags Details

Description Alice0775 White 2012-01-06 06:49:09 PST
Created attachment 586410 [details]
testcase

Build Identifier:
http://hg.mozilla.org/mozilla-central/rev/5413ba3ed406
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:12.0a1) Gecko/20120105 Firefox/12.0a1 ID:20120105083933

Tooltip(title attibute of the element) pops up even if the element has been removed.

Reproducible: Always

Steps to Reproduce:
1. Open Firefox with clean profile
2. Open tescase
3. Click "click to remove this element"
4. And stay mouse pointer(do not move mouse).

Actual Results:
  tooltip will pop up.
  
Expected Results:
  Tooltip should not pop up.



Regression window(cached m-c hourly),
Works:
http://hg.mozilla.org/mozilla-central/rev/7898841a922a
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:7.0a1) Gecko/20110630 Firefox/7.0a1 ID:20110702004346
Fails:
http://hg.mozilla.org/mozilla-central/rev/7b44ed36faf3
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:7.0a1) Gecko/20110702 Firefox/7.0a1 ID:20110702022656
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=7898841a922a&tochange=7b44ed36faf3



Regression window(cached m-i hourly),
Works:
http://hg.mozilla.org/integration/mozilla-inbound/rev/cdc314af3241
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:7.0a1) Gecko/20110630 Firefox/7.0a1 ID:20110630121221
Fails:
http://hg.mozilla.org/integration/mozilla-inbound/rev/11e4980826aa
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:7.0a1) Gecko/20110630 Firefox/7.0a1 ID:20110630150117
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=cdc314af3241&tochange=11e4980826aa


Triggered by:
Bug 664058 - Kill AddEventListenerByIID/RemoveEventListenerByIID from layout
Comment 1 yvoschu 2012-01-22 23:38:28 PST
I can't reproduce this with the latest Nightly.

AFAICS this was fixed by https://hg.mozilla.org/mozilla-central/rev/e70f6f04cf0f for Bug 715999

Note You need to log in before you can comment on or make changes to this bug.