Last Comment Bug 715883 - Remove JSRuntime::gcEmptyArenaPoolLifespan
: Remove JSRuntime::gcEmptyArenaPoolLifespan
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: unspecified
: x86_64 Linux
: -- normal (vote)
: ---
Assigned To: Igor Bukanov
:
: Jason Orendorff [:jorendorff]
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-01-06 06:49 PST by Igor Bukanov
Modified: 2012-01-31 05:33 PST (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
v1 (4.92 KB, patch)
2012-01-06 06:50 PST, Igor Bukanov
gal: review+
Details | Diff | Splinter Review

Description Igor Bukanov 2012-01-06 06:49:13 PST
JSRuntime::gcEmptyArenaPoolLifespan is no longer used for anything, but we still have have the code to read/write it. We should remove it.
Comment 1 Igor Bukanov 2012-01-06 06:50:45 PST
Created attachment 586411 [details] [diff] [review]
v1

The patch removes unused code.
Comment 3 Tony Mechelynck [:tonymec] 2012-01-15 16:33:45 PST
Bug 716232 (SEGV crash in JS garbage collection code at ChatZilla startup) appeared about when this patch landed. Could someone please have a look?
Comment 5 Igor Bukanov 2012-01-30 13:05:58 PST
https://hg.mozilla.org/mozilla-central/rev/7c34bef1d9ea - this has landed to mc some time ago
Comment 6 Igor Bukanov 2012-01-30 13:09:29 PST
(In reply to Tony Mechelynck [:tonymec] from comment #3)
> Bug 716232 (SEGV crash in JS garbage collection code at ChatZilla startup)
> appeared about when this patch landed. Could someone please have a look?

This bug just eliminates unused code and unused field from JSRuntime. Sometimes such changes could trigger a regression, but typically such regression would be a serious bug that would be rather visible. Do you have more indications that this bug indeed caused that ChatZilla problem?
Comment 7 Tony Mechelynck [:tonymec] 2012-01-31 05:33:59 PST
(In reply to Igor Bukanov from comment #6)
> (In reply to Tony Mechelynck [:tonymec] from comment #3)
> > Bug 716232 (SEGV crash in JS garbage collection code at ChatZilla startup)
> > appeared about when this patch landed. Could someone please have a look?
> 
> This bug just eliminates unused code and unused field from JSRuntime.
> Sometimes such changes could trigger a regression, but typically such
> regression would be a serious bug that would be rather visible. Do you have
> more indications that this bug indeed caused that ChatZilla problem?

That ChatZilla problem appeared between the SeaMonkey nightlies built around half past midnight Mountain View time on the 6th (last good) and 7th (first bad) of January. I tried to determine which changesets were "most likely" to have caused the regression and noted the results of my detective work in bug 716232 comment #5

Since Jan.7 (and never before that) I experience a SEGV crash at every startup of ChatZilla-on-trunk in both Firefox and SeaMonkey; the top symbol on the crash stack is not strictly constant but always in the JS garbage collector and often at symbols with "Arena" in their names.

Note You need to log in before you can comment on or make changes to this bug.