If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Unable to edit profile on MDN after linking new BrowserID login with old account

VERIFIED WORKSFORME

Status

Mozilla Developer Network
Wiki pages
VERIFIED WORKSFORME
6 years ago
4 years ago

People

(Reporter: kats, Unassigned)

Tracking

unspecified
x86
Mac OS X

Details

(Whiteboard: u=user c=browserid p=1)

STR:

1. Have a MDN login from before the BrowserID switch
2. Try to log in to BrowserID, go through the BrowserID flow (I had to create a BrowserID, verify it, and then I linked it to my old login via the "returning MDN users" thing)
3. Get booted back out of MDN for some reason
4. Log in to MDN again with BrowserID
5. Use shift+refresh to actually get the logged-in version with the user toolbar thing at the top
6. Go to User Tools -> Edit my profile

Expected results:
I'm able to see/edit my profile

Actual results:
I get a permission denied page that tells me to try logging in. The user toolbar at the top goes back to having just the "Sign In" button. However, I am signed in (I can access other MDN pages and edit them).
Target Milestone: --- → 2.0
Target Milestone: 2.0 → 2.1
:kats thanks for the bug report.

I can't reproduce this now. It may have been caused by MindTouch API issues we had last Thursday and Friday. 

Raymond, can you spend some time trying to reproduce this? If you can't reproduce it, please mark 'WORKSFORME'
Assignee: nobody → mozbugs.retornam
Whiteboard: u=user c=browserid p=1
So the "User Tools -> Edit my profile" thing I was trying to use before seems to be gone now; clicking on my username in header and then the "Edit Profile" works fine now. So the issue I filed this bug for is fixed although it would be good if you guys could verify the migration flow just to make sure. I can't since I can't create a pre-BrowserID account on the site :)
Ah, the User Tools -> Edit my profile link is in the MindTouch header. We've since updated it to point to the django "Edit Profile" page which is the right one.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
Status: RESOLVED → VERIFIED
(Assignee)

Updated

5 years ago
Component: Website → Landing pages
Product: Mozilla Developer Network → Mozilla Developer Network
Assignee: mozbugs.retornam → nobody
You need to log in before you can comment on or make changes to this bug.