Breadcrumb on Support Forum should look like an obvious navigation tool

VERIFIED FIXED in 2012-02-07

Status

VERIFIED FIXED
7 years ago
7 years ago

People

(Reporter: bram, Assigned: rrosario)

Tracking

unspecified
2012-02-07

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: u=user c=questions s=2012.2 p=1, URL)

Attachments

(3 attachments)

(Reporter)

Description

7 years ago
The breadcrumb is the only way to go up the level from a specific entry, for example:
https://support.mozilla.org/en-US/questions/910041

To the full list of questions:
https://support.mozilla.org/en-US/questions/


But
1) it’s not big enough to be clickable, and
2) it doesn’t look like it serves a navigational purpose
(Reporter)

Updated

7 years ago
Component: Knowledge Base Software → Forum
QA Contact: kb-software → forum
Whiteboard: u=user c=forum s=2012.2 p=
Component: Forum → Questions
QA Contact: forum → questions
Whiteboard: u=user c=forum s=2012.2 p= → u=user c=questions s=2012.2 p=
Bram, can you provide the UI for this?
(Reporter)

Comment 2

7 years ago
Created attachment 587005 [details]
Text breadcrumb

The breadcrumb style that Mozilla.com is using
(Reporter)

Comment 3

7 years ago
Created attachment 587007 [details]
Text breadcrumb, no home icon
(Reporter)

Comment 4

7 years ago
Created attachment 587010 [details]
Button breadcrumbs, square

Styling breadcrumbs into buttons make them more targetable
Can we combine both? The buttons are a good improvement over the mozilla.com style, but now it's not clear that there is a hierarchy.
(Reporter)

Comment 6

7 years ago
I was thinking of implementing a breadcrumb navigation with arrowed buttons (chevron) similar to The Guardian: http://www.guardian.co.uk/environment/ethical-living

Arrowed buttons has the benefit of being more helpful than square ones (ie. they have a direction) or just text (ie. they give you a clearly marked clickable area).
(Reporter)

Comment 7

7 years ago
Demo (note that the rightmost text should not be hover-able because it indicates the current page):
http://people.mozilla.com/~bpitoyo/sumo/breadcrumb/breadcrumb.html
(Assignee)

Updated

7 years ago
Whiteboard: u=user c=questions s=2012.2 p= → u=user c=questions s=2012.2 p=1
(Assignee)

Comment 8

7 years ago
Going with Comment 7.

Per discussion during planning, we will apply this to all breadcrumbs on the site.
Assignee: nobody → rrosario
There is a nice, and simple solution that works with CSS only (no images and no JS), here: http://css-tricks.com/triangle-breadcrumbs/

Updated

7 years ago
Priority: -- → P3
(Assignee)

Comment 10

7 years ago
https://github.com/mozilla/kitsune/commit/f38728a6cfc10adc888c05d299ad02fd795948b6
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → 2012-02-07
Verified implementation of new breadcrumbs. Filed bug 723366 relating to display on Firefox 9 & 10.
Status: RESOLVED → VERIFIED
We need to use the One Mozilla style of breadcrumbs as shown on 

http://careers.mozilla.org
Status: VERIFIED → REOPENED
Resolution: FIXED → ---

Updated

7 years ago
Status: REOPENED → UNCONFIRMED
Ever confirmed: false

Updated

7 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 13

7 years ago
This already shipped today and was verified, probably was better to file a new bug. How urgent is this? I assume there are plenty of more changes coming for the One Mozilla redesign?
Priority: P3 → --
Whiteboard: u=user c=questions s=2012.2 p=1 → u=user c=questions s=2012.3 p=1
Target Milestone: 2012-02-07 → 2012Q1
Yes, please don't reopen bugs marked VERIFIED, just file a new one.
Status: NEW → RESOLVED
Last Resolved: 7 years ago7 years ago
Resolution: --- → FIXED
Filed bug 725287.

-> VERIFIED by comment 11.
Status: RESOLVED → VERIFIED
(Assignee)

Comment 16

7 years ago
undoing my previous changes :-)
Whiteboard: u=user c=questions s=2012.3 p=1 → u=user c=questions s=2012.2 p=1
Target Milestone: 2012Q1 → 2012-02-07
You need to log in before you can comment on or make changes to this bug.