Last Comment Bug 716108 - [New Tab Page] “Connecting…” should not briefly flicker in the tab title when a new tab is opened
: [New Tab Page] “Connecting…” should not briefly flicker in the tab title when...
Status: RESOLVED FIXED
[Snappy:P1]
:
Product: Firefox
Classification: Client Software
Component: Tabbed Browser (show other bugs)
: Trunk
: All All
: -- normal with 2 votes (vote)
: Firefox 17
Assigned To: Tim Taubert [:ttaubert]
:
Mentors:
: 738923 749038 (view as bug list)
Depends on:
Blocks: 724494 752839 764971
  Show dependency treegraph
 
Reported: 2012-01-06 15:17 PST by Jennifer Morrow [:Boriss] (UX)
Modified: 2012-10-24 05:23 PDT (History)
18 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
verified


Attachments
Mockup: Removing the "Connecting..." string (197.39 KB, image/png)
2012-01-06 15:17 PST, Jennifer Morrow [:Boriss] (UX)
no flags Details
patch v1 (2.65 KB, patch)
2012-01-19 17:35 PST, Tim Taubert [:ttaubert]
no flags Details | Diff | Review
patch v1 (2.65 KB, patch)
2012-03-08 23:23 PST, Tim Taubert [:ttaubert]
no flags Details | Diff | Review
patch v2 (3.79 KB, patch)
2012-07-21 05:06 PDT, Tim Taubert [:ttaubert]
gavin.sharp: review+
akeybl: approval‑mozilla‑aurora+
Details | Diff | Review

Description Jennifer Morrow [:Boriss] (UX) 2012-01-06 15:17:36 PST
Created attachment 586586 [details]
Mockup: Removing the "Connecting..." string

Currently, the text string “Connecting…” appears very briefly in the title of a newly-created tab before the text is replaced with “New Tab.”  This text should not appear for two reasons.  First,  because it’s visible for too short a time to be read, and no text we display should be unreadable.  Second, because it’s inaccurate, as New Tab uses cached rather data and requires no connection.

The tab should be blank before “New Tab” displays, and preferably “New Tab” would be displayed so fast as to appear instantaneous on a new tab.
Comment 1 Bill Gianopoulos [:WG9s] 2012-01-06 15:27:20 PST
Hmm. I don't see this (at least in Linux crating a new tab by clicking on the new tab button.)

Exactly what OS is this under and how are you opening the new tab where you see this.  This sounds like the kind of thing I could actually help fix, but so far can;t duplicate.
Comment 2 Dão Gottwald [:dao] 2012-01-06 16:00:57 PST
I don't see this either. Something like this does happen if you restore a session with blank tabs.
Comment 3 Tim Taubert [:ttaubert] 2012-01-08 07:44:06 PST
I can't reproduce that. Did you maybe try with an older version of the UX branch? Even when restoring a session with blank tabs (or the new tab page) this doesn't happen for me.
Comment 4 Jennifer Morrow [:Boriss] (UX) 2012-01-10 17:14:53 PST
(In reply to Tim Taubert [:ttaubert] from comment #3)
> I can't reproduce that. Did you maybe try with an older version of the UX
> branch? Even when restoring a session with blank tabs (or the new tab page)
> this doesn't happen for me.

My UX branch was few days out of date.  Once I updated, I couldn't reproduce this - I guess this got fixed!  I marked "fixed" for now, and will reopen if I see the sucker again.
Comment 5 Tim Taubert [:ttaubert] 2012-01-19 17:23:58 PST
Reopening, this is valid again (see bug 455553 comment #149).
Comment 6 Tim Taubert [:ttaubert] 2012-01-19 17:35:42 PST
Created attachment 590066 [details] [diff] [review]
patch v1

Prevents "Connecting..." from flickering in the tab title and hides the throbber for the New Tab Page.
Comment 7 Guillaume C. [:ge3k0s] 2012-01-20 01:37:54 PST
I think it has already been said, but the new tab favicon should go away.
Comment 8 Tim Taubert [:ttaubert] 2012-01-25 06:54:26 PST
(In reply to GE3K0S from comment #7)
> I think it has already been said, but the new tab favicon should go away.

That's bug 685059.
Comment 9 Tim Taubert [:ttaubert] 2012-03-08 23:23:11 PST
Created attachment 604316 [details] [diff] [review]
patch v1

unrotted
Comment 10 Tim Taubert [:ttaubert] 2012-03-19 08:10:53 PDT
Gavin: I know we talked about this on IRC and the consequences of touching this code are not totally understood, yet. What can I do to bring this into a landable state? It's a rather minor visual glitch but I think we would really profit from having this fixed.
Comment 11 Marco Bonardo [::mak] 2012-03-24 08:24:16 PDT
*** Bug 738923 has been marked as a duplicate of this bug. ***
Comment 12 Tim Taubert [:ttaubert] 2012-04-26 06:16:09 PDT
*** Bug 749038 has been marked as a duplicate of this bug. ***
Comment 13 Virgil Dicu [:virgil] [QA] 2012-05-07 07:36:06 PDT
I would also vote for this. It's pretty disturbing when multiple tabs are already opened and the new tab page is activated - especially on slower computers.
Comment 14 Marco Castelluccio [:marco] 2012-06-14 11:43:07 PDT
We could do this for every in-content page, should I open a new bug?
Comment 15 (dormant account) 2012-06-14 12:13:56 PDT
(In reply to Marco Castelluccio from comment #14)
> We could do this for every in-content page, should I open a new bug?

that's a good idea.
Comment 16 (dormant account) 2012-07-19 15:39:06 PDT
p1 because this looks like a fairly small fix which should result in less tab bar flicker.
Comment 17 Tim Taubert [:ttaubert] 2012-07-21 05:06:48 PDT
Created attachment 644623 [details] [diff] [review]
patch v2

New approach. The mBlank flag on a tab's progress listener indicates that the tab starts blank and we don't want to show the throbber until the first load has finished and we receive STATE_STOP.

The previous patch called browser.stop() to stop loading about:blank (which immediately resets the mBlank flag) and then set mBlank to true again.

I think the better way to achieve this is to call browser.stop() *before* we create a tab's progress listener. This way there's not artificial STATE_STOP notification that resets mBlank.

For bug 764971, we could rename the parameter to something like "aDontShowThrobberForFirstLoad" and see if the URI passed to addTab() is in a list of content pages.
Comment 18 Tim Taubert [:ttaubert] 2012-07-21 10:58:04 PDT
Try is green:

https://tbpl.mozilla.org/?tree=Try&rev=8e469328d876

I know we don't have any explicit tests for this but at least we know we didn't break any basic expectations.
Comment 19 Tim Taubert [:ttaubert] 2012-07-24 14:42:01 PDT
https://hg.mozilla.org/integration/fx-team/rev/c7c9c6e428d3
Comment 20 Tim Taubert [:ttaubert] 2012-07-25 00:43:00 PDT
https://hg.mozilla.org/mozilla-central/rev/c7c9c6e428d3
Comment 21 Siddhartha Dugar [:sdrocking] 2012-07-25 00:57:35 PDT
This will be good to have on Aurora.
Comment 22 Tim Taubert [:ttaubert] 2012-07-25 01:58:41 PDT
Comment on attachment 644623 [details] [diff] [review]
patch v2

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 455553
User impact if declined: Flickering tab title when opening new tabs.
Testing completed (on m-c, etc.): Will be in today's Nightly.
Risk to taking this patch (and alternatives if risky): Low risk.
String or UUID changes made by this patch: None.
Comment 23 Alex Keybl [:akeybl] 2012-07-26 16:09:50 PDT
Comment on attachment 644623 [details] [diff] [review]
patch v2

[Triage Comment]
This doesn't meet our typical bar for uplift, but given where we are in the 16 cycle, and the fact that this is low risk, we'll take the polish.
Comment 24 Tim Taubert [:ttaubert] 2012-07-27 04:34:59 PDT
(In reply to Alex Keybl [:akeybl] from comment #23)
> This doesn't meet our typical bar for uplift, but given where we are in the
> 16 cycle, and the fact that this is low risk, we'll take the polish.

Awesome, thank you!

https://hg.mozilla.org/releases/mozilla-aurora/rev/559bb27b0def
Comment 25 Nicolas Barbulesco 2012-08-25 04:15:01 PDT
Hello,

Firefox 14.0.1. Win Vista.

I encounter this bug when I create a new blank tab.
Comment 26 :Gavin Sharp [email: gavin@gavinsharp.com] 2012-08-25 16:52:13 PDT
This bug was fixed for Firefox 16, so it's expected that you would still see it in Firefox 14.0.1.
Comment 27 Virgil Dicu [:virgil] [QA] 2012-09-11 06:07:58 PDT
Mozilla/5.0 (X11; Linux i686; rv:16.0) Gecko/20100101 Firefox/16.0

Setting this to verified in 16 beta 2. Verified on Ubuntu 12.04, Mac OS 10.7, Windows 7 and XP. Also checked slower hardware-no tab animation regressions following this fix.

Note You need to log in before you can comment on or make changes to this bug.