Closed Bug 716190 Opened 8 years ago Closed 8 years ago

Fennec just flashes when loading google.com

Categories

(Firefox for Android :: General, defect, P2)

ARM
Android
defect

Tracking

()

VERIFIED FIXED
Firefox 12
Tracking Status
firefox11 --- verified
firefox12 --- verified
fennec 11+ ---

People

(Reporter: wlach, Assigned: snorp)

Details

Attachments

(3 files)

Using the Nightly from Friday January 6th 2012 on my LG G2X (Android 2.2), I just get a whole bunch of flashing (between white and black) when I load a basic site like google.ca. The actual website is never accessible. Looking at logcat, I'm seeing a lot of scary output like this:

D/BrowserProvider(25916): [query] tablename=bookmarks, whereClause=(url = 'google.ca/' OR url = 'www.google.ca/' OR url = 'http://google.ca/' OR url = 'http://www.google.ca/')
D/GeckoLayerController(25872): setPageSize: v=RectF(36.962265, 3.0517578E-5, 516.9623, 699.0) p=(740.0,768.0) z=1.6485848 o=0.0,0.0
W/GraphicBufferMapper(25872): lock(...) failed -16 (Device or resource busy)
E/GeckoSoftwareLayerClient(25872): Bad viewport description: 
W/System.err(25872): java.lang.RuntimeException: org.json.JSONException: End of input at character 0 of 
W/System.err(25872): 	at org.mozilla.gecko.gfx.GeckoSoftwareLayerClient.updateViewport(GeckoSoftwareLayerClient.java:201)
W/System.err(25872): 	at org.mozilla.gecko.gfx.GeckoSoftwareLayerClient.endDrawing(GeckoSoftwareLayerClient.java:212)
W/System.err(25872): 	at org.mozilla.gecko.GeckoAppShell.nativeRun(Native Method)
W/System.err(25872): 	at org.mozilla.gecko.GeckoAppShell.nativeRun(Native Method)
W/System.err(25872): 	at org.mozilla.gecko.GeckoAppShell.runGecko(GeckoAppShell.java:460)
W/System.err(25872): 	at org.mozilla.gecko.GeckoThread.run(GeckoThread.java:107)
W/System.err(25872): Caused by: org.json.JSONException: End of input at character 0 of 
W/System.err(25872): 	at org.json.JSONTokener.syntaxError(JSONTokener.java:446)
W/System.err(25872): 	at org.json.JSONTokener.nextValue(JSONTokener.java:93)
W/System.err(25872): 	at org.json.JSONObject.<init>(JSONObject.java:154)
W/System.err(25872): 	at org.json.JSONObject.<init>(JSONObject.java:171)
W/System.err(25872): 	at org.mozilla.gecko.gfx.GeckoSoftwareLayerClient.updateViewport(GeckoSoftwareLayerClient.java:173)
W/System.err(25872): 	... 5 more

(full log also attached)
Did it used to work on this phone or is this the first time you've used the nightly?
(In reply to James Willcox (:snorp) (jwillcox@mozilla.com) from comment #1)
> Did it used to work on this phone or is this the first time you've used the
> nightly?

Nightly worked as of December 20th 2011 (that was the last version of nightly that still worked for me). Aurora still works.
Assignee: nobody → snorp
tracking-fennec: --- → 11+
Priority: -- → P2
This is blocking our progress on Eideticker automation as this is our main phone we use (it has reliable mirrored HDMI out).  I'm requesting making this a P1, please.
So the nightly from today seems somewhat more functional, sometimes it seems to work ok, though it's fairly easy to trigger the flashing by loading a more complicated site like the new york times (happens maybe 50% of the time). In case it helps, I uploaded a webm video of the flashiness:

http://people.mozilla.com/~wlachance/flashy_fennec.webm

Looking at the adb log, it looks like many of the same error messages are still there. Going to attach a more recent copy.
Comment on attachment 588525 [details] [diff] [review]
Retry graphic buffer locks if we get -EBUSY

Review of attachment 588525 [details] [diff] [review]:
-----------------------------------------------------------------

Do you know if this fixes the problem reported in the bug?

::: widget/android/AndroidDirectTexture.cpp
@@ -84,5 @@
>  bool
>  AndroidDirectTexture::Lock(PRUint32 aUsage, unsigned char **bits)
>  {
> -  mLock.Lock();
> -  ReallocPendingBuffer();

Why was ReallocPendingBuffer() removed?
(In reply to Patrick Walton (:pcwalton) from comment #7)
> Comment on attachment 588525 [details] [diff] [review]
> Retry graphic buffer locks if we get -EBUSY
> 
> Review of attachment 588525 [details] [diff] [review]:
> -----------------------------------------------------------------
> 
> Do you know if this fixes the problem reported in the bug?

If it would be useful, I can test this fix on my phone next week.
(In reply to Patrick Walton (:pcwalton) from comment #7)
> Comment on attachment 588525 [details] [diff] [review]
> Retry graphic buffer locks if we get -EBUSY
> 
> Review of attachment 588525 [details] [diff] [review]:
> -----------------------------------------------------------------
> 
> Do you know if this fixes the problem reported in the bug?

It fixes it for me, yes. Or at least improves it substantially.

> 
> ::: widget/android/AndroidDirectTexture.cpp
> @@ -84,5 @@
> >  bool
> >  AndroidDirectTexture::Lock(PRUint32 aUsage, unsigned char **bits)
> >  {
> > -  mLock.Lock();
> > -  ReallocPendingBuffer();
> 
> Why was ReallocPendingBuffer() removed?

Because it changes to the other Lock() method which acquires the mLock, calls ReallocPendingBuffer, etc.
Comment on attachment 588525 [details] [diff] [review]
Retry graphic buffer locks if we get -EBUSY

Review of attachment 588525 [details] [diff] [review]:
-----------------------------------------------------------------

r=me.
Attachment #588525 - Flags: review?(pwalton) → review+
https://hg.mozilla.org/mozilla-central/rev/6da5a83a4a5c
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 12
Comment on attachment 588525 [details] [diff] [review]
Retry graphic buffer locks if we get -EBUSY

[Triage Comment]
Attachment #588525 - Flags: approval-mozilla-aurora+
Verified on M-A & M-C
Galaxy Nexus (Android 4.0.3)

20120126053754
http://hg.mozilla.org/releases/mozilla-aurora/rev/9d5ede8cb11a

20120126031113
http://hg.mozilla.org/mozilla-central/rev/402b394b6623
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.