Toolbar buttons can get focus in modern theme.

VERIFIED DUPLICATE of bug 71460

Status

SeaMonkey
Themes
VERIFIED DUPLICATE of bug 71460
17 years ago
9 years ago

People

(Reporter: Yoshiki Yazawa, Assigned: Joe Hewitt (gone))

Tracking

({modern})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Since March 8, toolbar buttons can get focus in modern theme.

(1) Load some URL in a browser window.
(2) Click back button on toolbar to load previous URL.
(3) Press space key. Navigator backs insted of page down.

This is focusing problem. Back button gets focus after it was clicked on,
so following key input go to back button. 

On March 8, some focus properties in
mozilla/themes/modern/communicator/button.css, were altered like this:

-  -moz-user-focus: ignore !important;
+  -moz-user-focus: ignore;

I'm not sure how "!important" works, but reverting these solves problem.

Comment 1

17 years ago
Adding modern keyword.
Keywords: modern

Comment 2

17 years ago
CC'ing hwaara. Like you did for the broken menubuttons, could you come up with
the patch real quick and check it in? ;)
Thanks.
(Assignee)

Comment 3

17 years ago

*** This bug has been marked as a duplicate of 71460 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 4

17 years ago
verified dup
Status: RESOLVED → VERIFIED
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.