10x regression when using lots of switches

RESOLVED WORKSFORME

Status

()

Core
JavaScript Engine
RESOLVED WORKSFORME
6 years ago
6 years ago

People

(Reporter: azakai, Unassigned)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Comment hidden (empty)
(Reporter)

Comment 1

6 years ago
Created attachment 586712 [details]
testcase (zlib)

This testcase has become 10x slower with 83343:eaac85c4c05f

http://hg.mozilla.org/mozilla-central/rev/eaac85c4c05f

The regression is with |-m -n|. I guess this is because of additional analysis now done in switches. The bug mentions that bug 709614 will help here.
(Reporter)

Updated

6 years ago
Blocks: 704387
Depends on: 706914
(Reporter)

Comment 2

6 years ago
Err, that should have been bug 706914 in the last comment, sorry (I did get the "depends on" right though ;)
Blocks: 579390
(Reporter)

Comment 3

6 years ago
Bug 706914 has landed, but seems to not help here.
(Reporter)

Comment 4

6 years ago
This appears to not be an issue anymore. -n makes it 17% slower but at least not 10x.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Resolution: FIXED → WORKSFORME
You need to log in before you can comment on or make changes to this bug.