Unable to submit app: field required error on step 3

RESOLVED FIXED

Status

RESOLVED FIXED
7 years ago
3 years ago

People

(Reporter: kumar, Unassigned)

Tracking

Details

Attachments

(1 attachment)

Created attachment 586741 [details]
field required error on step 3

Submitting this app manifest http://pidoco.com/pidoco.webapp resulted in a 'field required' error on step 3 but no way to edit the field since it was hidden. The user was on Linux using Firefox 8 and Chrome 16. Attached is a screenshot of the error.

Originally reported at http://groups.google.com/group/mozilla-apps/browse_thread/thread/29cc70049f70ba97
I can't reproduce it on Mac, clouserw maybe you can try on Linux?
I can't.  I originally replied to him on the 5th:

> Hi Silvan,
> 
> The layout of your screenshot is not what you should be seeing.  It's
> missing the "Name" <input> completely (I suspect that's the missing
> field) and the "More detailed description" box is also completely gone.
>  Do you have any add-ons modifying the pages in Firefox?  Can you try
> uploading with a clean browser profile?  I attempted to upload your
> manifest and it looks fine to me with Firefox.
> 
> If that doesn't work, we can file a bug and get some developers on it,
> but I'm afraid we won't even be able to reproduce this.

There was no reply.  We've updated the site since the original report, I don't think there is much to do in this bug.

Comment 3

7 years ago
Hi everyone, thanks for answering.

I am the one who originally experienced the bug. A couple of days later I tried it again. This time the process worked. I cannot see that I did something different this time, I was using the same browser. It is possible that I edited the json meanwhile but I think only the translations section.

If you updated the site between the submissions of app 94 and 112 (just in case you have a time stamp in the db, probably around 2011-12-30) then the bug is probably fixed. Not sure if these numbers are real ids but it's what I have seen in the url [1] during the submission process.

However app 94 still is in some kind of intermediate state. If I go to [1] I can still see the same bug like in the screenshot posted above. And because of this  I had to choose a new name (Pidoco° instead of Pidoco) and a new slug (/app/pidoco-wireframe-creator instead of /app/pidoco), because the old names have already been taken. That's not a big deal for me (although I would have preferred the old name and slug). But if I can help you find the error (as it may happen to others) just contact me or take a look at app-94.

[1] https://apps-preview.mozilla.org/en-US/developers/app/app-94/submit/3

Best regards and thanks
Silvan
calling this fixed. thanks.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
(Assignee)

Updated

3 years ago
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.