Closed Bug 716335 Opened 9 years ago Closed 6 years ago

Enabling Hardware acceleration is causing Padlock problems with latest NVIDIA driver version 285.62. Works fine in 280.26

Categories

(Core :: Graphics, defect)

9 Branch
x86_64
Windows 7
defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: Shashwat2691, Unassigned)

References

()

Details

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:9.0.1) Gecko/20100101 Firefox/9.0.1
Build ID: 20111220165912

Steps to reproduce:

1. Completely Uninstalled Firefox with tool "Total Uninstall"
2. Delete all files from Application Data folder.
3. Installed a fresh copy of Firefox 9.0.1
4. Run Firefox in safe mode. (Works fine)
5. Reset everything in Firefox (from box that opens before running Firefox in safe mode). It did not work
6. Turn off hardware acceleration.
7. Uninstalled NVIDIA and Intel HD graphics driver.
8. Installed latest Intel HD and NVIDIA graphics driver. (NVIDIA Version 285.62)
9. Nothing Helped.
10. I downgraded NVIDIA driver again to 280.26 version. (I had upgraded it 5-6 days ago)
11. It works fine with NVIDIA 280.26 version

https://support.mozilla.org/en-US/questions/909935

For an instance of my issue
When ever we install an add on a dialog box appears for further interaction just below the padlock (like https://support.mozilla.org/media/uploads/images/2012-01-07-21-28-41-911af7.png)
But I don't see dialog even if I click on extension icon
It appears like (https://support.mozilla.org/media/uploads/images/2012-01-07-21-19-48-911af7.png)

Same problem with "remember password" dialog and "Sharing geographic Location" and for looking on website Identity. Dialog box below padlock never opens.
Everything that interacts with Padlock does not work properly


Actual results:

In safe mode it was working perfect.
It works when Hardware acceleration is turned off (Graphics performance got down)
It worked fine with NVIDIA 280.26 with Hardware acceleration turned on. (Best graphics performance)


Expected results:

It should work fine with latest NVIDIA version 285.62
For an instance:
When ever we install an add on a dialog box appears for further interaction just below the padlock (like https://support.mozilla.org/media/uploads/images/2012-01-07-21-28-41-911af7.png)
But I don't see dialog even if I click on extension icon
It appears like (https://support.mozilla.org/media/uploads/images/2012-01-07-21-19-48-911af7.png)

Same problem with "remember password" dialog and "Sharing geographic Location" and for looking on website Identity. Dialog box below padlock never opens.
Everything that interacts with Padlock does not work properly
Severity: normal → critical
Priority: -- → P1
This works with older nvidia drivers but doesn't work with the latest one ?
This looks like a bug in the new driver.
Do you reported this to nvidia ?
Severity: critical → normal
Priority: P1 → --
I think you are right.
Let me look how to report to nvidia
Duplicate of this bug: 716966
Status: UNCONFIRMED → NEW
Component: Untriaged → Graphics
Ever confirmed: true
Product: Firefox → Core
QA Contact: untriaged → thebes
Depends on: 716396
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.