If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

feDisplacementMap test shows unexpected colors

VERIFIED FIXED in Firefox 28

Status

()

Core
SVG
VERIFIED FIXED
6 years ago
4 years ago

People

(Reporter: heycam, Assigned: mstange)

Tracking

(Blocks: 1 bug)

Trunk
mozilla28
All
Mac OS X
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox28 verified)

Details

Attachments

(2 attachments)

+++ This bug was initially created as a clone of Bug #619967 +++

http://dev.w3.org/SVG/profiles/1.1F2/test/harness/htmlObjectMiniApproved/filters-displace-02-f.html currently fails due to some strange colors near the edge of the displaced image.
(Assignee)

Comment 1

4 years ago
I don't know why but my patches in bug 924102 and bug 924103 fix this test. I added some bilinear interpolation for fractional source locations, and maybe I've changed the rounding in some way.
(Assignee)

Comment 2

4 years ago
Resolving as fixed by bug 924103, even though the test now fails because of the new feDisplacement taintedness restrictions (bug 941887). But before bug 941887 landed, this was fixed.
Assignee: nobody → mstange
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Depends on: 924103
Resolution: --- → FIXED
Target Milestone: --- → mozilla28
status-firefox28: --- → fixed
Keywords: verifyme
Created attachment 8381306 [details]
screenshots.zip

I'm not sure I was able to reproduce this issue: I've tried with both the Nightly from 2012-01-09 and Firefox 4. Does anyone have any thoughts/suggestions?

Please see the attached screenshots for more details (there is also the result I'm seeing on beta)
Flags: needinfo?(mstange)
28 beta 6 seems completely broken but not in the way that Cam saw as far as I know. Nightly and Firefox 4 look OK.
(Assignee)

Comment 5

4 years ago
(In reply to Robert Longson from comment #4)
> 28 beta 6 seems completely broken but not in the way that Cam saw as far as
> I know.

It's broken due to bug 941887, intentionally.

> Nightly and Firefox 4 look OK.

This is surprising to me. I recall a purple fringe at the end of the gradient, but it's not visible in these screenshots. Maybe it only showed on Mac?
Flags: needinfo?(mstange)
Yes, the fringe was mac only.
Created attachment 8381348 [details]
Screen Shot beta.png

I was able to reproduce the issue shown here https://bug619967.bugzilla.mozilla.org/attachment.cgi?id=498401 with Firefox 4 on Mac OS X 10.8.5.

On the same machine, with Firefox 28 beta 6 I see the same behavior as on Windows (also shown in this attachement). Considering beta it's broken due to bug 941887 intentionally, is it safe to call this bug verified on 28 branch?
Flags: needinfo?(mstange)

Updated

4 years ago
OS: All → Mac OS X
(Assignee)

Comment 8

4 years ago
Yes.
Flags: needinfo?(mstange)

Updated

4 years ago
Status: RESOLVED → VERIFIED
status-firefox28: fixed → verified

Updated

4 years ago
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.