Status

Thunderbird
General
--
critical
RESOLVED INVALID
7 years ago
6 years ago

People

(Reporter: s.fendrich, Unassigned)

Tracking

({crash, stackwanted})

9 Branch
x86
Linux
crash, stackwanted

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (X11; Linux i686; rv:9.0.1) Gecko/20100101 Firefox/9.0.1
Build ID: 20111220165912

Steps to reproduce:

Anything I try to do with attachments, e.g.
a. open an attachment: left click on an attachment
b. save an attachment: right click on an attachment, then click "save as" and select a destination
c. attach an attachment: click "write", then "attach"
d. configure attachments: click "edit", then "preferences", then "attachments"


Actual results:

attachments are handled as expected, but thunderbird crashes



Expected results:

thunderbird should not crash
Can you provide a crash ID from about:crashes ?
The easiest way to get the crash id is to install https://addons.mozilla.org/de/thunderbird/addon/viewabout/
(Reporter)

Comment 2

7 years ago
(In reply to Matthias Versen (Matti) from comment #1)
> Can you provide a crash ID from about:crashes ?
> The easiest way to get the crash id is to install
> https://addons.mozilla.org/de/thunderbird/addon/viewabout/

Thank you for the response. Unfortunately there are no crash reports and I don't get them enabled. My ~/.thunderbird/Crash Reports/crashreporter.ini looks like this:

[Crash Reporter]
Enabled=1
EmailMe=0
SubmitReport=1

Meanwhile I have found out that there are some error messages:
At startup:
failed to create drawable
/usr/lib/gio/modules/libgsettingsgconfbackend.so: undefined symbol: gconf_value_free
Failed to load module: /usr/lib/gio/modules/libgsettingsgconfbackend.so

At crash:
/opt/thunderbird/thunderbird-bin: symbol lookup error: /usr/lib/gnome-vfs-2.0/modules/libfile.so: undefined symbol: gnome_vfs_unescape_string
I somehow missed that you are on linux and that you are very likely using a build from your distribution. The crash reporter works only on Mozilla.org builds because the symbols are extracted during the build process and have to be uploaded to the Mozilla crash server.

This looks like http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=626076
(Reporter)

Comment 4

7 years ago
Yes, the workaround proposed at http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=626076 works for me, too:
in /etc/gnome-vfs-2.0/modules/default-modules.conf
uncomment "file: file", that is:
#file: file
Yeah, that looks like the same ld.so bug. You should upgrade your libc.

Comment 6

6 years ago
(In reply to Mike Hommey [:glandium] from comment #5)
> Yeah, that looks like the same ld.so bug. You should upgrade your libc.

bug invalid?
Severity: normal → critical
Keywords: crash, stackwanted
Invalid if confirmed that this is the same problem.

Comment 8

6 years ago
(In reply to Mike Hommey [:glandium] from comment #7)
> Invalid if confirmed that this is the same problem.

http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=626076 is going nowhere. However, please reopen this you feel this is still a thunderbird problem.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → INVALID
(In reply to Wayne Mery (:wsmwk) from comment #8)
> (In reply to Mike Hommey [:glandium] from comment #7)
> > Invalid if confirmed that this is the same problem.
> 
> http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=626076 is going nowhere.

How is it going nowhere? It's been fixed for a while now.

Comment 10

6 years ago
(In reply to Mike Hommey [:glandium] from comment #9)
> (In reply to Wayne Mery (:wsmwk) from comment #8)
> > (In reply to Mike Hommey [:glandium] from comment #7)
> > > Invalid if confirmed that this is the same problem.
> > 
> > http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=626076 is going nowhere.
> 
> How is it going nowhere? It's been fixed for a while now.

guess I'm no good at reading debian reports
You need to log in before you can comment on or make changes to this bug.