Truncated French translation for "Run Junk Mail Controls on Folder"



Mozilla Localizations
fr / French
6 years ago
6 years ago


(Reporter: Mossroy, Assigned: Bugzilla FR)


Firefox Tracking Flags

(Not tracked)



(1 attachment)



6 years ago
Created attachment 586819 [details]
Thunderbird truncated translation.png

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:10.0) Gecko/20100101 Firefox/10.0
Build ID: 20120105170210

Steps to reproduce:

I installed Ubuntu 12.04 alpha 1 with updates. It provides a Thunderbird 10.0 beta version (more precisely 10.0~b1+build1-0ubuntu1_amd64)
I installed the French translation for Thunderbird (package thunderbird-locale-fr), ran Thunderbird, and opened the menu "Tools" ("Outils" in French)

Actual results:

The menu "Run Junk Mail Controls on Folder" is translated "Traquer les indésirables dans le dos..."
The menu "Delete Mail Marked As Junk in Folder" is translated "Supprimer les indésirables de ce dos..."

Expected results:

These translations are truncated. The last word should be "dossier" ("folder" in English) instead of "dos..."
In French, the word "dos" means "back" (in a human body). So this truncated translation means "run junk mail controls in your back..."!
I found it funny, but I'm not sure it was on purpose ;-)

The translation should not be truncated, and "dos..." should be replaced by "dossier".
If it's not possible (maybe it is considered too long), it would be better to rephrase it.

Comment 1

6 years ago
The build Id of this version of Thunderbird is 20111223024324

Based on the diff from , the translations do not seem to be modified by Ubuntu : that's why I opened this bug here.
Anyway, just let me know if I should have opened it on Ubuntu bugtracker.
Severity: normal → minor


6 years ago
Assignee: nobody →
Component: General → fr / French
Product: Thunderbird → Mozilla Localizations
QA Contact: general → benoit.leseul
Version: 10 → unspecified
I can't reproduce on Ubuntu 12.04 but I use a Thunderbird build from Mozilla not the one in the repo. Do you still see the problem ?

Comment 3

6 years ago
Yes, I confirm the problem is still there on Ubuntu 12.04.1, with Thunderbird from standard ubuntu repository, and all updates installed.
All you have to do is install an Ubuntu 12.04, in French language (with Internet access, so that all translations are downloaded), then start Thunderbird and open the menu "Outils" (Tools in English)
Do you see the bug with Unity only or do you see it as well with another environment? (I don't see the bug with Gnome Shell).

Comment 5

6 years ago
Hey : you're right.
If I use a classic gnome session, the label is not truncated
If I use Unity or Unity2D, the label is truncated.

So I suppose this is a Unity-specific issue, that I should open on launchpad. And this issue can be closed as invalid or similar status

Sorry for the inconvenience, I did not think that Unity might truncate menu labels...
Last Resolved: 6 years ago
Resolution: --- → INVALID
no problem :) When you have filed the bug in Launchpad, could you put the launchpad bug number in this bug for reference please? Thanks

Comment 7

6 years ago
I opened the bug on launchpad :
You need to log in before you can comment on or make changes to this bug.