Larry panel (clicking on favicon in location bar) flickers or is invisible with hardware acceleration enabled

RESOLVED WORKSFORME

Status

()

Core
Graphics
RESOLVED WORKSFORME
6 years ago
2 years ago

People

(Reporter: Ben Turner (not reading bugmail, use the needinfo flag!), Unassigned)

Tracking

11 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

The larry panel (click on the favicon in the location bar) flickers or is invisible with hardware acceleration enabled. This only started happening a few days ago when I updated my video drivers. Here's the info from about:support.

Adapter Description: Intel(R) HD Graphics Family
Vendor ID: 0x8086
Device ID: 0x0126
Adapter RAM: Unknown
Adapter Drivers: igdumd64 igd10umd64 igd10umd64 igdumdx32 igd10umd32 igd10umd32
Driver Version: 8.15.10.2538
Driver DateL 9-26-2011
Direct2D Enabled: true
DirectWrite Enabled: true (6.1.7601.17563)
ClearType Parameters: ClearType parameters not found
WebGL Renderer: Blocked for your graphics card because of unresolved driver issues.
GPU Accelerated Windows: 1/1 Direct3D 10
AzureBackend: direct2d

If I disable hardware acceleration via preferences dialog then larry works just fine. This happens on my local builds as well as nightly builds, even on a clean profile.
Oh, and the menu must exist but is invisible, because if you click where the 'More info' button should be the page info dialog comes up!
Disabling what specifically fixes it? gfx.direct2d or layers.acceleration?
(In reply to Benoit Jacob [:bjacob] from comment #2)
> Disabling what specifically fixes it? gfx.direct2d or layers.acceleration?

Whatever is in the preferences dialog... Advanced->General->"Use hardware acceleration when available"
That disables everything. Can you try disabling individual features in about:config?
Looks like gfx.direct2d.disabled is the magic pref. Flipping that makes the dropdown work again.

Also, another thing I figured out, if I tell NVIDIA control panel to use the "high performance NVIDIA processor" instead of the "integrated graphics" for Firefox then the dropdown also works. Think this is just some bug in my particular driver?
is bug 716335 a dupe of this one ?
(In reply to Matthias Versen (Matti) from comment #6)
> is bug 716335 a dupe of this one ?

Almost certainly.
Blocks: 716335
It would be interesting to know if this has always happened, or it is recent. Can you try it with older versions of Firefox?
Keywords: regressionwindow-wanted
Is this still an Issue with a recent Firefox Version and/or Intel HD Graphics Driver Version (e.g. 15.22.54.64.2622 off http://downloadcenter.intel.com/Detail_Desc.aspx?lang=eng&changeLang=true&DwnldId=20842)?
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Keywords: regressionwindow-wanted
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.