Closed Bug 716449 Opened 11 years ago Closed 11 years ago

[Windows 2000] "nsLocalFileWin.h(60) : error C2065: 'PCIDLIST_ABSOLUTE' : undeclared identifier"

Categories

(Core :: Widget: Win32, defect)

x86
Windows 2000
defect
Not set
blocker

Tracking

()

RESOLVED WONTFIX
Tracking Status
firefox9 --- wontfix
firefox10 --- wontfix
firefox11 - wontfix
firefox12 --- wontfix
firefox-esr10 --- wontfix

People

(Reporter: sgautherie, Assigned: sgautherie)

References

()

Details

(Keywords: regression)

[I had not tried to do a local (Firefox, optimized) build for maybe 2 years...]

{
nsDirectoryService.cpp
...\xpcom\io\nsLocalFileWin.h(60) : error C2065: 'PCIDLIST_ABSOLUTE' : undeclared identifier
...\xpcom\io\nsLocalFileWin.h(60) : error C2275: 'UINT' : illegal use of this type as an expression
        ...\Microsoft Platform SDK for Windows Server 2003 R2\include\windef.h(172) : see declaration of 'UINT'
...\xpcom\io\nsLocalFileWin.h(61) : error C2065: 'PCUITEMID_CHILD_ARRAY' : undeclared identifier
...\xpcom\io\nsLocalFileWin.h(62) : error C2275: 'DWORD' : illegal use of this type as an expression
        ...\Microsoft Platform SDK for Windows Server 2003 R2\include\windef.h(151) : see declaration of 'DWORD'
...\xpcom\io\nsLocalFileWin.h(62) : error C2165: 'left-side modifier' : cannot modify pointers to data
...\xpcom\io\nsLocalFileWin.h(62) : error C2513: 'HRESULT *' : no variable declared before '='
make[6]: *** [nsDirectoryService.obj] Error 2
}

***

http://msdn.microsoft.com/en-us/library/windows/desktop/bb773321(v=vs.85).aspx
{
PCIDLIST_ABSOLUTE: The ITEMIDLIST is absolute and constant. This is typically used when you are passed an absolute ITEMIDLIST as a parameter but do not own it, and so are not allowed to change it.

Minimum supported client	Windows XP
}

http://msdn.microsoft.com/en-us/windows/bb762232
{
Type: PCUITEMID_CHILD_ARRAY
A pointer to an array of PIDL structures, each of which is an item to select in the target folder referenced by pidlFolder.

Minimum supported client	Windows XP
}

It looks like this is a 2003R2 SDK or Windows 2000 issue.
Code should be "fixed", or bug 629827 and/or bug 629825...
Probably an SDK issue; I can't even compile with the Vista SDK without a few extra #ifdef in gfx/ although I think the Windows 7 SDK still works.
Serge could you go into your mozilla-build directory and type:
guess-msvc.bat > out.txt

Then paste the contents of out.txt here?
I'd like to setup the same environment as you so I can reproduce this exactly on a VM.  Also please paste your .mozconfig.
(In reply to Brian R. Bondy [:bbondy] from comment #2)

> Serge could you go into your mozilla-build directory and type:
> guess-msvc.bat > out.txt

My guess-msvc.bat file is tweaked to bypass reg.exe (which isn't shipped with Win2k),
so I simply "force" the following values:
{
Visual C++ 8 Express directory: x:\Program Files\Microsoft Visual Studio 8\VC
Platform SDK directory: x:\Program Files\Microsoft Platform SDK for Windows Server 2003 R2
Platform SDK version: 5
}

In other words: Win2k sp4 + vc8ee sp1 + p.sdk 2003R2.

> I'd like to setup the same environment as you so I can reproduce this
> exactly on a VM.  Also please paste your .mozconfig.

{
mk_add_options MOZ_OBJDIR=...
ac_add_options --enable-application=browser

ac_add_options --with-windows-version=502
ac_add_options --disable-webm
ac_add_options --disable-angle
ac_add_options --disable-libjpeg-turbo
ac_add_options --disable-ctypes
}

Fwiw, you might (I'm not fully sure, but it is worth a try.) be able to reproduce with some more recent environments, by using just '--with-windows-version=502'.
> ac_add_options --with-windows-version=502
It would be removed by bug 699385 anyway.
(In reply to Serge Gautherie (:sgautherie) from comment #0)
> Code should be "fixed", or bug 629827 and/or bug 629825...

(In reply to Masatoshi Kimura [:emk] from comment #4)
> > ac_add_options --with-windows-version=502
> It would be removed by bug 699385 anyway.

Right, but that bug is currently delayed.
Hence my 3 choices from comment 0.
(In reply to neil@parkwaycc.co.uk from comment #1)
> Probably an SDK issue; I can't even compile with the Vista SDK without a few
> extra #ifdef in gfx/ although I think the Windows 7 SDK still works.

It looks like I hit that othr bug while trying to check this one:
I filed bug 717499 ;-<


(In reply to Serge Gautherie (:sgautherie) from comment #3)
> reproduce with some more recent environments, by using just
> '--with-windows-version=502'.

https://tbpl.mozilla.org/?tree=Try&rev=790b578ddb7c
https://tbpl.mozilla.org/php/getParsedLog.php?id=8492165&tree=Try&full=1
WINNT 5.2 try build on 2012-01-11 15:22:30 PST for push 790b578ddb7c
{
...
nsBinaryStream.cpp

nsDirectoryService.cpp
d:/mozilla-build/python25/python2.5.exe -O e:/builds/moz2_slave/try-w32/build/build/cl.py cl [...] /e/builds/moz2_slave/try-w32/build/xpcom/io/nsDirectoryService.cpp
nsDirectoryService.cpp

nsEscape.cpp
...
}

Just that option was not enough to reproduce this bug on Try :-|
Keywords: regression
(In reply to Serge Gautherie (:sgautherie) from comment #6)
> > '--with-windows-version=502'.
> 
> Just that option was not enough to reproduce this bug on Try :-|

https://tbpl.mozilla.org/?tree=Try&rev=762726cf55f7
Even with all my local options, it isn't reproducible on Try.
It looks like this bug depends on actually not having involved softwares installed, or being on Windows 2000...
(In reply to Serge Gautherie (:sgautherie) from comment #7)
> It looks like this bug depends on actually not having involved softwares
> installed, or being on Windows 2000...

Involved softwares are: VC8EE (not professional), no Vista/7 SDK, etc.
Depends on: Win2kRemoval
Bug 670068 was fixed in mozilla9: it added the line with PCIDLIST_ABSOLUTE.
Bug 685847 was fixed in mozilla9: it replaced then restored that PCIDLIST_ABSOLUTE use.
Blocks: 670068
No longer depends on: 670068
Depends on: PSDK2003R2Removal
No longer depends on: Win2kRemoval
Assignee: nobody → sgautherie.bz
Status: NEW → ASSIGNED
Affected FF10 without any dupes - not tracking for FF11 (although we'd consider taking a low-risk fix if found early in the cycle).
Status: ASSIGNED → RESOLVED
Closed: 11 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.