Opening a link with HTTP protocol with thunderbird returns a js exception

RESOLVED DUPLICATE of bug 682984

Status

Thunderbird
OS Integration
RESOLVED DUPLICATE of bug 682984
6 years ago
5 years ago

People

(Reporter: brunoais, Unassigned)

Tracking

9 Branch
x86_64
Windows 7

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
When I try to open an url in thunderbird with the HTTP protocol the js throws an exception.
The exception is:

Error: Component returned failure code: 0x80520012 (NS_ERROR_FILE_NOT_FOUND) [nsIExternalProtocolService.loadUrl]
Source file: chrome://communicator/content/contentAreaClick.js
Line: 188

Which is inside the function: openLinkExternally(url)
in which url is a string that starts with http:.
The code is this one:

right here:
Components.classes["@mozilla.org/uriloader/external-protocol-service;1"]
            .getService(Components.interfaces.nsIExternalProtocolService)
            .loadUrl(uri);


This exception happens inside any page of the program where it may open an external link.
Tried this to fix:
Safe mode
Safe mode + no remote
Safe mode + no remote + changing default browser (repeated this for 3 browsers (including IE))
Safe mode + changing default browser (repeated this for all 3 browsers (including IE))

None worked.
(Reporter)

Comment 1

6 years ago
I also tried to reinstall thunderbird and try again in safe mode. Still didn't work
entering http://www.mozilla.org windows:start/run is working as expected ?
(Reporter)

Comment 3

6 years ago
if I use the window's run window (pressing windows key + R) to go to http://www.mozilla.org it works as expected (firefox opens for the link).
Just tried. The link to this page is working in thunderbird but that's because it uses the https protocol.

Updated

6 years ago
Priority: P3 → --
Target Milestone: Thunderbird 10.0 → ---

Comment 4

5 years ago
Can you see if this is the same as bug 682984? There are some workarounds there that you can try.
(Reporter)

Comment 5

5 years ago
Thanks aceman.
It was a wrong path in that file.
I was able to make some changes and then I was able to fix in the GUI about opening files.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME

Comment 6

5 years ago
Cool. But we'd like TB to inform about that properly so the report is valid, just dupe it to bug 682984.
Resolution: WORKSFORME → DUPLICATE
Duplicate of bug: 682984
You need to log in before you can comment on or make changes to this bug.