Changing to unthreaded view in Virtual Folder doesn't resort message list

RESOLVED FIXED

Status

Thunderbird
Folder and Message Lists
RESOLVED FIXED
6 years ago
2 years ago

People

(Reporter: nONoNonO, Unassigned)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
I've seen this for a long time, but hadn't checked for a bug until now.

Steps to reproduce:
Change the sort order of a virtual folder to Sort by Date.
View the messages Threaded.
View the messages Unthreaded again.

Actual results:
Thread pane isn't sorted by date.

Expected results:
Thread pane is sorted by date.

You have to change the sort order to something else and than back to date to sort the list. Or alternatively you have to select another folder and then come back to the virtual folder to have it sorted by date.

For a normal folder this works as expected, but on a virtual folder changing to unthreaded view just removes the threading...

Comment 1

6 years ago
(In reply to Onno Ekker from comment #0)
Which version of Thunderbird are you using?
(Reporter)

Comment 2

6 years ago
I'm using Thunderbird 11.0a2 (Earlybird) at the moment, but this behavior is also seen in Thunderbird 9.0.1. I'm not sure if it matters, but I see this on an IMAP account.

Comment 3

4 years ago
Onno, I can't reproduce using current daily build.
Can you still reproduce?
Flags: needinfo?(o.e.ekker)
(Reporter)

Comment 4

4 years ago
Yes, I can still reproduce this with current Daily 25.0a1, even in safe-mode.
I've created a virtual folder under by IMAP Inbox named All Mail matching all messages from my Inbox and my Sent folder where I see this behavior. Maybe that's needed info to reproduce?
Flags: needinfo?(o.e.ekker)
(Reporter)

Updated

3 years ago
Blocks: 236849

Comment 5

2 years ago
Fixed by Bug 1192838 and friends.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.