Closed Bug 716473 Opened 10 years ago Closed 10 years ago

Mozilla Maintenance Service uninstaller asks the user to stop the service

Categories

(Toolkit :: Application Update, defect)

x86_64
Windows 7
defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla12

People

(Reporter: hsivonen, Assigned: bbondy)

References

Details

Attachments

(2 files)

Steps to reproduce:
 1) Install Nightly with the default options so that Mozilla Maintenance Service gets installed.
 2) Click Uninstall a program in Control Panel
 3) Select Mozilla Maintenance Service
 4) Click Uninstall/Change

Actual results:
The window that shows up says (in part): "Before starting the uninstallation, make sure Mozilla Maintenance Service is not running." How is the user supposed to know how to do that?

Expected results:
Expected the uninstall wizard not to talk about making sure the service isn't running. Expected the uninstaller to take care of making sure the service isn't running during uninstallation.
Based on what I see for "Google Update Service" in web searches, this is going to be something users try to do. We should make sure this works as expected and that the uninstall doesn't leave behind a broken fx install.
This is already handled correctly we just need to remove that text. 

That is the standard string we use in installer and we need to make a new one that will get localized in future versions.
I'd like to simplify (lessen the pages shown) the installer and uninstaller for the maintenance service. For this we could likely get away with just removing the intro page for now.
So no prompt at all? Or just a different message box "are you sure?" type prompt?
Assignee: nobody → netzen
Attachment #587560 - Flags: review?(robert.bugzilla)
Attachment #587562 - Flags: feedback?(robert.bugzilla)
I tried with just a summary page but it's a bit strange because it doesn't ask you to uninstall it just says the product is uninstalled, click finish to continue.
Sorry, I meant the confirmation page.
Comment on attachment 587560 [details] [diff] [review]
1 page confirm only uninstaller. Patch v1.

I think this is fine for the initial release. Please file a followup bug for reworking the install and uninstall for the maintenance service and we'll get input from UX for it.
Attachment #587560 - Flags: review?(robert.bugzilla) → review+
Attachment #587562 - Flags: feedback?(robert.bugzilla) → feedback+
Pushed to inbound:
http://hg.mozilla.org/integration/mozilla-inbound/rev/f757bd8bcf7d

I'll post a follow up bug about a reworked installer w/ UX input in a few minutes.
Target Milestone: --- → mozilla12
Blocks: 718887
https://hg.mozilla.org/mozilla-central/rev/f757bd8bcf7d
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.