Canceling the Firefox uninstaller shows a Program compatibility assistant window (ditto Mozilla Maintenance Service uninstaller)

RESOLVED WORKSFORME

Status

()

Firefox
Installer
RESOLVED WORKSFORME
6 years ago
3 months ago

People

(Reporter: hsivonen, Unassigned)

Tracking

Trunk
x86_64
Windows 7
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [DUPEME])

Steps to reproduce:
 1) Install Nightly with the default options so that Mozilla Maintenance Service gets installed.
 2) Click Uninstall a program in Control Panel
 3) Select Mozilla Maintenance Service
 4) Click Uninstall/Change
 5) Click Cancel in the window that shows up

Actual results:
A Windows-generated dialog pops up that says (in part): "This program might not have uninstalled correctly". Four choices are offered to the user: Close (as the "X" button on top right), "Cancel", "Uninstall using recommended settings" and "This program uninstalled correctly". I didn't dare to try what "Uninstall using recommended settings" does, but it sure looks scary.

Expected results:
Expected to get back to the program list in Control Panel without any additional Windows-generated UI.
The Firefox uninstaller also does this. 
But I think this will go away once bug 716480 lands.
Please retest once that is marked as fixed on the following Nightly.
Depends on: 716480
Summary: Canceling the Mozilla Maintenance Service uninstaller shows a scary Windows-generated prompt → Canceling the Firefox uninstaller shows a Program compatibility assistant window (ditto Mozilla Maintenance Service uninstaller)
I can reproduce this with both the service uninstaller and Firefox uninstaller, even with the Firefox release uninstaller. So I renamed the subject appropriately.
I think there is already a bug on this. I don't recall if the NSIS version in the latest MozillaBuild fixes this but it very well might in which case upgrading the build systems to the latest MozillaBuild will fix this.
Whiteboard: [DUPEME]
I think I read previously in a forum that a newer NSIS version does fix this, but I may be wrong there.
Component: Application Update → Installer
Product: Toolkit → Firefox
Doesn't reproduce anymore. Newer NSIS version must have fixed it.
Status: NEW → RESOLVED
Last Resolved: 3 months ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.