Last Comment Bug 716481 - Spellcheck icon stays disabled if clicking on a mailto link with a subject parameter, or replying (any action where the cursor starts in the body field)
: Spellcheck icon stays disabled if clicking on a mailto link with a subject pa...
Status: RESOLVED FIXED
[gs]
: regression
Product: Thunderbird
Classification: Client Software
Component: Message Compose Window (show other bugs)
: 9 Branch
: All All
: -- major (vote)
: Thunderbird 13.0
Assigned To: Mark Banner (:standard8)
:
Mentors:
https://getsatisfaction.com/mozilla_m...
: 719650 719970 (view as bug list)
Depends on:
Blocks: 680511
  Show dependency treegraph
 
Reported: 2012-01-09 02:51 PST by Michael Fischer
Modified: 2012-02-26 04:42 PST (History)
12 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
-
affected
+
fixed
fixed
11+
fixed


Attachments
HTML example links for reproducing the problem (274 bytes, text/plain)
2012-01-09 02:51 PST, Michael Fischer
no flags Details
The fix (807 bytes, patch)
2012-02-21 03:13 PST, Mark Banner (:standard8)
iann_bugzilla: review+
standard8: approval‑comm‑aurora+
standard8: approval‑comm‑beta+
Details | Diff | Splinter Review

Description Michael Fischer 2012-01-09 02:51:35 PST
Created attachment 586939 [details]
HTML example links for reproducing the problem

User Agent: Mozilla/5.0 (Windows NT 5.1; rv:9.0.1) Gecko/20100101 Firefox/9.0.1
Build ID: 20111220165912

Steps to reproduce:

Clicking on a mailto-link with a subject parameter (with or without body parameter).
See attached html-file for examples of such links.



Actual results:

A Thunderbird message compose window opens with the cursor already located in the mail body area. The spell check icon in the toolbar stays disabled (greyed out).



Expected results:

The spell check icon should be enabled. Like when you click on a normal mailto link (without parameters) and then manually move the cursor to the mail body area.
Comment 1 Michael Fischer 2012-01-09 02:55:18 PST
Reproduced on Windows XP, Windows 7 and Ubuntu Linux.
Bug is present in Version 9.01 and 10.0b1 but not in Thunderbird 8.0

Workaround:
Click on subject or recipient fields and then click back to the mail body area.
Comment 2 Hashem Masoud 2012-01-09 23:39:39 PST
(In reply to Michael Fischer from comment #1)
Works for me. The spell check button is not greyed out. I tried the mailto link in your attachment having subject and body.
User Agent: Mozilla/5.0 (X11; Linux i686; rv:9.0) Gecko/20111222 Thunderbird/9.0.1
Application Build ID: 20111222141531

Try it without addons (start Thunderbird in safe-mode) and check.
Comment 3 Charles 2012-01-10 09:52:23 PST
I am having a similar problem now with 9.0.1, as are others in our office, but it has nothing to do with mailto links...

If I write a *new* message, spellcheck works as expected.

However, if I *Reply* to any message, the Spellcheck button is disabled/greyed out, unless/until I SHIFT+TAB then TAB to move the cursor from the body to the subject and then back to the body. This re-enables the spellcheck button/functionality every time.
Comment 4 Charles 2012-01-10 10:09:01 PST
Incidentally, we also use spellcheck on Send, and that is working (at least for me), even  though the button is greyed out (so cannot do a manual spellcheck).
Comment 5 Michael Fischer 2012-01-10 11:55:23 PST
Forgot to say that I tried in safe-mode and
User-Agent: Mozilla/5.0 (Windows NT 5.1; rv:9.0) Gecko/20111222 Thunderbird/9.0.1

I can also confirm Charles issue with the reply button.

Spellcheck on Send works of course but you can't select the language as long as the button is grayed out. Also my coworkers find it annoying and prefer only "mark as you type".
Comment 6 Ludovic Hirlimann [:Usul] 2012-01-11 07:35:56 PST
Can you guys hunt when this regressed ?
Comment 7 Michael Fischer 2012-01-11 13:00:15 PST
(In reply to Ludovic Hirlimann [:Usul] from comment #6)
> Can you guys hunt when this regressed ?

You mean find out in which version this error first occurred?
In 8.0 it worked fine, in 9.0.1 it was broken. If you could point me to a server where I can download the intermediate versions, I could try to find it out.
Comment 8 Joe Smith 2012-01-19 00:34:51 PST
(In reply to Charles from comment #3)
> I am having a similar problem now with 9.0.1, as are others in our office,
> but it has nothing to do with mailto links...
> 
> If I write a *new* message, spellcheck works as expected.
> 
> However, if I *Reply* to any message, the Spellcheck button is
> disabled/greyed out, unless/until I SHIFT+TAB then TAB to move the cursor
> from the body to the subject and then back to the body. This re-enables the
> spellcheck button/functionality every time.

Same here: When replying to first e-mail after start of TB (by clicking on the "reply" button), the spell check button in the opening message composition window is grayed out. The spell check works at the same time - i.e. the language one used earlier is still checked, but the problem is that one cannot change the language, because the button is grayed out.

As mentioned in previous comments, the workaround is changing the cursor to the subject or recipient field, and back to the main message field. Also, the problem does not appear on the second message one replies to later.

It seems that the problem does not appear on when a new message is composed (instead of replying), because, when replying, the cursor is automatically positioned in the main text field of the composition window, as opposed to the "recipient" field when a new message is composed.

I'm not 100 percent sure, but I think it came in a version before 9. Maybe in 8 or so. One of the later ones, anyway.

----------------------------
TB information (German version):

  Allgemeine Informationen

    Name: Thunderbird
    Version: 9.0.1
    User-Agent: Mozilla/5.0 (Windows NT 5.1; rv:9.0) Gecko/20111222 Thunderbird/9.0.1
    Profilordner: Beinhaltenden Ordner anzeigen

              (Lokaler Datenträger)
    Build-ID der Anwendung: 20111222160251
    Aktivierte Plugins: about:plugins
    Build-Konfiguration: about:buildconfig
    Absturzberichte: about:crashes

  E-Mail- und Newsgruppen-Konten
    account1:
      INCOMING: account1, , (imap) imap.gmx.net:993, SSL, passwordCleartext
      OUTGOING: mail.gmx.net:465, SSL, passwordCleartext, true
      OUTGOING: mail.gmx.net:465, SSL, passwordCleartext, false
      OUTGOING: mail.gmx.net:465, SSL, passwordCleartext, false
      OUTGOING: mail.gmx.net:465, SSL, passwordCleartext, false
      OUTGOING: mail.gmx.net:465, SSL, passwordCleartext, false
      OUTGOING: mail.gmx.net:465, SSL, passwordCleartext, false

    account2:
      INCOMING: account2, , (none) Local Folders, plain, passwordCleartext

    account3:
      INCOMING: account3, , (rss) Feeds, plain, passwordCleartext

  Erweiterungen
    Highlighter, 0.6.5, true, andre.rodier-highlighter@gmailcom
    Russian spellchecking dictionary, 0.4.4, true, ru@dictionaries.addons.mozilla.org
    Test Pilot for Thunderbird, 1.3.4, true, tbtestpilot@labs.mozilla.com
    United States English Spellchecker, 5.0.1, true, en-US@dictionaries.addons.mozilla.org
    Wörterbuch Deutsch (de-DE), Hunspell-unterstützt, 20111003, true, de_DE@dicts.j3e.de

  Modifizierte Einstellungen

    Name: Wert

      accessibility.typeaheadfind.flashBar: 0
      extensions.lastAppVersion: 9.0.1
      gfx.blacklist.direct2d: 2
      gfx.blacklist.layers.direct3d10: 2
      gfx.blacklist.layers.direct3d10-1: 2
      mail.openMessageBehavior.version: 1
      network.cookie.cookieBehavior: 2
      network.cookie.prefsMigrated: true
      places.database.lastMaintenance: 1326727977
      places.history.expiration.transient_current_max_pages: 26585
      places.history.expiration.transient_optimal_database_size: 42534666
      print.print_printer: PDFCreator
      print.printer_PDFCreator.print_bgcolor: false
      print.printer_PDFCreator.print_bgimages: false
      print.printer_PDFCreator.print_command:
      print.printer_PDFCreator.print_downloadfonts: false
      print.printer_PDFCreator.print_edge_bottom: 0
      print.printer_PDFCreator.print_edge_left: 0
      print.printer_PDFCreator.print_edge_right: 0
      print.printer_PDFCreator.print_edge_top: 0
      print.printer_PDFCreator.print_evenpages: true
      print.printer_PDFCreator.print_footercenter:
      print.printer_PDFCreator.print_footerleft: &PT
      print.printer_PDFCreator.print_footerright: &D
      print.printer_PDFCreator.print_headercenter:
      print.printer_PDFCreator.print_headerleft: &T
      print.printer_PDFCreator.print_headerright: &U
      print.printer_PDFCreator.print_in_color: true
      print.printer_PDFCreator.print_margin_bottom: 0.393750011920929
      print.printer_PDFCreator.print_margin_left: 0.5
      print.printer_PDFCreator.print_margin_right: 0.5
      print.printer_PDFCreator.print_margin_top: 0.393750011920929
      print.printer_PDFCreator.print_oddpages: true
      print.printer_PDFCreator.print_orientation: 0
      print.printer_PDFCreator.print_page_delay: 50
      print.printer_PDFCreator.print_pagedelay: 500
      print.printer_PDFCreator.print_paper_data: 9
      print.printer_PDFCreator.print_paper_height: 11,00
      print.printer_PDFCreator.print_paper_size_type: 0
      print.printer_PDFCreator.print_paper_size_unit: 1
      print.printer_PDFCreator.print_paper_width: 8,50
      print.printer_PDFCreator.print_reversed: false
      print.printer_PDFCreator.print_scaling: 1,00
      print.printer_PDFCreator.print_shrink_to_fit: true
      print.printer_PDFCreator.print_to_file: false
      print.printer_PDFCreator.print_unwriteable_margin_bottom: 0
      print.printer_PDFCreator.print_unwriteable_margin_left: 0
      print.printer_PDFCreator.print_unwriteable_margin_right: 0
      print.printer_PDFCreator.print_unwriteable_margin_top: 0
      security.OCSP.require: true

  Grafik

    Karten-Beschreibung: Intel(R) Graphics Media Accelerator 3150
    Vendor-ID: 8086
    Geräte-ID: a011
    Karten-RAM: Unknown
    Karten-Treiber: igxprd32
    Treiber-Version: 6.14.10.5134
    Treiber-Datum: 9-24-2009
    Vendor-ID (GPU #2): 8086
    Geräte-ID (GPU #2): a012
    Karten-RAM (GPU #2): Unknown
    Karten-Treiber (GPU #2): Unknown
    Treiber-Version (GPU #2): 6.14.10.5134
    Treiber-Datum (GPU #2): 9-24-2009
    WebGL-Renderer: Wurde auf Grund Ihrer Grafiktreiberversion blockiert. Versuchen Sie, Ihren Grafiktreiber auf mindestens Version 6.14.10.5260 zu aktualisieren.
    GPU-beschleunigte Fenster: 0/1. Wurde auf Grund Ihrer Grafiktreiberversion blockiert. Versuchen Sie, Ihren Grafiktreiber auf mindestens Version 6.14.10.5260 zu aktualisieren.
Comment 9 Mark Banner (:standard8) 2012-01-21 02:34:09 PST
*** Bug 719970 has been marked as a duplicate of this bug. ***
Comment 10 Joe Sabash [:JoeS1] 2012-01-21 10:42:11 PST
Uh-Oh I can reproduce in
Mozilla/5.0 (Windows NT 5.0; rv:10.0) Gecko/20120118 Thunderbird/10.0
Comment 11 Joe Sabash [:JoeS1] 2012-01-21 13:06:48 PST
The "or replying (any action where the cursor starts in the body" symptom exist on:
Mozilla/5.0 (Windows NT 5.0; rv:12.0a1) Gecko/20120120 Thunderbird/12.0a1
If you try to reply a second time, you run into bug 567240 ..but the spellcheck icon is no longer grayed out.
Comment 12 Mark Banner (:standard8) 2012-01-21 13:52:04 PST
(In reply to Joe Sabash from comment #10)
> Uh-Oh I can reproduce in
> Mozilla/5.0 (Windows NT 5.0; rv:10.0) Gecko/20120118 Thunderbird/10.0

Seeing as this was reported against TB 9, that's not surprising.
Comment 13 Joe Sabash [:JoeS1] 2012-01-21 15:10:35 PST
I have a "feeling"(have not checked) that this bug has been around for a while, maybe since bug 178324 fix was checked in.(http://hg.mozilla.org/mozilla-central/rev/cabb8925dcd3) Maybe some of the unfixed dependent bugs there could be a clue. Bug 567240 which has a similar workaround, established that regression range.
Comment 14 Ludovic Hirlimann [:Usul] 2012-01-23 08:27:42 PST
(In reply to Michael Fischer from comment #7)
> (In reply to Ludovic Hirlimann [:Usul] from comment #6)
> > Can you guys hunt when this regressed ?
> 
> You mean find out in which version this error first occurred?
> In 8.0 it worked fine, in 9.0.1 it was broken. If you could point me to a
> server where I can download the intermediate versions, I could try to find
> it out.

http://ftp.mozilla.org/pub/mozilla.org/thunderbird/nightly/ using the comm-central builds.
Comment 15 Michael Fischer 2012-01-25 02:38:51 PST
Bug first occurs on the nightly builds of 20. August 2011:
http://ftp.mozilla.org/pub/mozilla.org/thunderbird/nightly/2011/08/2011-08-20-03-00-14-comm-central/
Build of 19. August does not have this issue.
Comment 16 Joe Sabash [:JoeS1] 2012-01-25 14:02:32 PST
Thanks for the regression testing Michael.
This bug is also present in:
Mozilla/5.0 (Windows NT 5.0; rv:12.0a1) Gecko/20120125 Thunderbird/12.0a1 ID:20120125030312
I never noticed since I use "Check as you type"
bug 581661 looks highly suspect
https://hg.mozilla.org/comm-central/rev/8bbd7b60e5a8

Set blocking based on the regression date.
Comment 17 Joe Sabash [:JoeS1] 2012-01-26 18:02:42 PST
I expect that most people use "Spellcheck as you type"
But for those that use manual spellcheck, this bug makes it appear that a major feature is not available.
This bug is present in Trunk, Branches and Beta
Bumping severity.
Adding cc's
Comment 18 Avner Falk 2012-01-27 00:09:52 PST
My two-cents' worth as a loyal Thunderbird user is that this bug could make users abandon Thunderbird and that it needs to be fixed with alacrity. Thanks.
Comment 19 Michael Fischer 2012-01-27 16:08:45 PST
(In reply to Joe Sabash from comment #17)
> I expect that most people use "Spellcheck as you type"
> But for those that use manual spellcheck, this bug makes it appear that a
> major feature is not available.

There's also the case of users that often change the language. I got noticed of the bug from our customer care employees that have to switch languages constantly (Switzerland with it's official four languages is a hard case for any spell-checker developer ;-)
Comment 20 Avner Falk 2012-01-28 00:45:16 PST
Israel with its three official and 123 unofficial languages is even harder and yet all the spell-checkers worked fine until Thunderbird 9 came along.
Comment 21 Mark Banner (:standard8) 2012-01-28 03:41:39 PST
Folks, I understand you may be frustrated, but please don't comment unless you are actively helping this bug move forward to being fixed.

Please re-read the etiquette before commenting again: https://bugzilla.mozilla.org/page.cgi?id=etiquette.html - bugzilla is a place we work, and it needs to be a nice place to work without these sorts of comments. If you wish to discuss this, please email me privately.

As regards to fixing the bug, we are actively tracking it for Thunderbird 11 (see the tracking-thunderbird11 flag), which means we'll be doing our best to fix it for that release.
Comment 22 Mark Banner (:standard8) 2012-02-21 00:05:00 PST
*** Bug 719650 has been marked as a duplicate of this bug. ***
Comment 23 Mark Banner (:standard8) 2012-02-21 02:54:36 PST
This is actually a regression from bug 680511. It removed some code that is obviously needed, although I'm currently pondering if it is possible to put that code back in a slightly better/correct manner.
Comment 24 Mark Banner (:standard8) 2012-02-21 03:13:29 PST
Created attachment 599080 [details] [diff] [review]
The fix

The issue is that we have disabled on the element on startup, and the code used to set it enabled.

Bug 680511 removed the shared code but only the disabled attribute from the element for SeaMonkey, hence breaking Thunderbird.

This patch seems to fix it (I was testing using reply to a newsgroup article, though there's other ways as well). The existing command handling seems to be good enough to ensure it is disabled at the correct times as well.
Comment 25 Mark Banner (:standard8) 2012-02-21 05:08:15 PST
Try server builds should start appearing here shortly:

https://ftp.mozilla.org/pub/mozilla.org/thunderbird/try-builds/bugzilla@standard8.plus.com-40b4b241f52a/
Comment 26 Avner Falk 2012-02-21 05:11:56 PST
The above link does not seem valid. However, the spell-checker in TB11b2 seems to work.
Comment 27 Mark Banner (:standard8) 2012-02-21 05:16:41 PST
(In reply to avner.falk@usa.net from comment #26)
> The above link does not seem valid.

I said shortly - i.e. in a little while, but not necessarily 3 minutes after I post the link.

> However, the spell-checker in TB11b2 seems to work.

Then you're not testing the exact problem listed in this bug.
Comment 28 Mark Banner (:standard8) 2012-02-21 05:18:41 PST
(In reply to Mark Banner (:standard8) from comment #27)
> (In reply to avner.falk@usa.net from comment #26)
> > The above link does not seem valid.
> 
> I said shortly - i.e. in a little while, but not necessarily 3 minutes after
> I post the link.

(apologies if this sounds harsh, I didn't mean it to).
Comment 29 Ian Neal 2012-02-21 05:51:14 PST
Comment on attachment 599080 [details] [diff] [review]
The fix

r=me
Comment 30 Mark Banner (:standard8) 2012-02-21 06:52:39 PST
Checked in: http://hg.mozilla.org/comm-central/rev/cf85b487f53c
Comment 31 Mark Banner (:standard8) 2012-02-21 06:53:11 PST
Comment on attachment 599080 [details] [diff] [review]
The fix

[Triage Comment]
Comment 33 Michael Fischer 2012-02-22 08:45:20 PST
Works here with todays nightly builds (tried only e-mail component, not the news component). Thanks a lot! Will the fix be also available to the esr branch?
Comment 34 Mark Banner (:standard8) 2012-02-22 09:42:39 PST
Yes it will be on the ESR for organisations, I forgot to update the bug when I landed it earlier today:

http://hg.mozilla.org/releases/comm-esr10/rev/740aa8a7fa8e
Comment 35 Avner Falk 2012-02-22 11:31:51 PST
For someone who is not a programmer, Status:RESOLVED FIXED means I can use the latest version of Thunderbird with the spell-checker enabled. Can you please send me a link to the build in which this bug is fixed? Thanks.
Comment 36 Mark Banner (:standard8) 2012-02-24 01:47:46 PST
(In reply to avner.falk@usa.net from comment #35)
> For someone who is not a programmer, Status:RESOLVED FIXED means I can use
> the latest version of Thunderbird with the spell-checker enabled. Can you
> please send me a link to the build in which this bug is fixed? Thanks.

The full fix will be in Thunderbird 11. For now you can test this with the beta builds here:

http://www.mozilla.org/en-US/thunderbird/channel/

(or you can use the Earlybird ones which are currently version 12, but the fix is there as well).
Comment 37 Charles 2012-02-24 04:29:45 PST
Someone maybe should update the Target Milestone - I was going to ask why this fix wasn't going to be available until Thunderbird 13, but am very happy to hear it will be available in 11...

Thanks guys!
Comment 38 Mark Banner (:standard8) 2012-02-24 04:58:28 PST
(In reply to Charles from comment #37)
> Someone maybe should update the Target Milestone - I was going to ask why
> this fix wasn't going to be available until Thunderbird 13, but am very
> happy to hear it will be available in 11...

The Target Milestone is the release at which it has landed in trunk. The status-thunderbird<nn> flags are the branch releases it lands in. This bug has both status-thunderbird12 and status-thunderbird11 marked as "fixed", so that gives you the additional information.
Comment 39 Charles 2012-02-24 10:14:32 PST
Oh, right, never noticed those. Thanks!

Note You need to log in before you can comment on or make changes to this bug.