Last Comment Bug 716495 - Copy and Close keyboard shortcuts on scratchpad are the same In some locales (es-AR, fr-FR at least)
: Copy and Close keyboard shortcuts on scratchpad are the same In some locales ...
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: Developer Tools: Scratchpad (show other bugs)
: 10 Branch
: All All
: P2 normal (vote)
: ---
Assigned To: Marcelo Poli
:
Mentors:
Depends on: 725269 725270 725271 725272 725274 725275
Blocks:
  Show dependency treegraph
 
Reported: 2012-01-09 04:07 PST by Leonard Camacho [:lcamacho]
Modified: 2012-08-02 11:55 PDT (History)
7 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Hotfix (2.95 KB, application/x-xpinstall)
2012-03-05 07:15 PST, Alexandre Poirot [:ochameau]
no flags Details

Description Leonard Camacho [:lcamacho] 2012-01-09 04:07:40 PST
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:12.0a1) Gecko/20120108 Firefox/12.0a1
Build ID: 20120108031024

Steps to reproduce:

After look at bug 709039 I try to confirm with es-* localizations and found that in es-AR localization this bug exist, I just left a message on mozilla hispano community to try to fix this

1. Open Scratchpad
2. Select some text
3. Press Copy shortcut (Ctrl+C)





Actual results:

Scratchpad close


Expected results:

The text shoul be copied
Comment 1 Mihai Sucan [:msucan] 2012-01-09 11:08:30 PST
Why is this bug assigned?
Comment 2 Marcelo Poli 2012-01-09 14:25:06 PST
(In reply to Mihai Sucan [:msucan] from comment #1)
> Why is this bug assigned?

Because I am going to commit the fix.
I just missed the "assigned to" field.
Comment 3 David Bruant 2012-01-25 10:47:48 PST
Has a fix been committed? In which version is the bug supposed to be fixed?
Comment 4 Marcelo Poli 2012-01-25 16:10:07 PST
(In reply to David Bruant from comment #3)
> Has a fix been committed? In which version is the bug supposed to be fixed?

Fixed in aurora, beta and central.
Comment 5 David Bruant 2012-01-26 13:29:26 PST
Same problem on fr-FR locale on Ubuntu, Aurora.
This problem may occur in other locales.
Comment 6 David Bruant 2012-02-04 08:22:13 PST
The bug remains in Aurora 12.0a2 (2012-02-03) for the fr-FR locale.
Comment 7 Mihai Sucan [:msucan] 2012-02-06 12:11:28 PST
I can also confirm this problem. I am using Firefox 11 beta (in French) from the Firefox team PPA on Ubuntu 10.04 LTS.

Ctrl-C closes Scratchpad, ouch. This is a localization problem that should be fixed before Firefox 11 final is out.
Comment 8 David Bruant 2012-02-08 01:16:15 PST
This affects Firefox 10 (current stable release) as well!
Comment 9 Mihai Sucan [:msucan] 2012-02-08 01:36:20 PST
That's sad.

Axel: anything that can be done about this bug? Someone should fix it for Firefox 11+.
Comment 10 David Bruant 2012-02-08 01:55:21 PST
Confirmed on Mac and Windows as well.
Comment 11 Axel Hecht [:Pike] 2012-02-08 05:13:12 PST
I filed bugs on each localization that had something conflicty in http://mxr.mozilla.org/l10n-mozilla-aurora/search?string=closeCmd.key&find=scratchpad.dtd$ .
Comment 12 Rob Campbell [:rc] (:robcee) 2012-03-05 06:54:42 PST
just got another report from a user that this is still a problem on 10.0.2a2 (aurora). We're one week away from merge. Any chance of this getting fixed?
Comment 13 Alexandre Poirot [:ochameau] 2012-03-05 06:59:28 PST
I'm hitting this bug on french locale for 10.0.2.
Scratchpad ends up being barely usable because of this.

I'm wondering if we can hotfix this bug with an addon that would override scrachpad.dtd??
Comment 14 Alexandre Poirot [:ochameau] 2012-03-05 07:15:19 PST
Created attachment 602896 [details]
Hotfix

Here is an hotfix example, works only for fr-FR locale.
We are currently trying to build an hotfix-as-addon feature, it may be a good candidate!
Comment 15 Rob Campbell [:rc] (:robcee) 2012-08-02 09:13:09 PDT
Is this still a problem in es-AR? Appears to be fixed in fr-FR. Can we close this?

Filter on BLACKEAGLE?!
Comment 16 Leonard Camacho [:lcamacho] 2012-08-02 10:14:30 PDT
It's fixed in es-AR, so I think we can close this bug.
Comment 17 Rob Campbell [:rc] (:robcee) 2012-08-02 11:55:30 PDT
happily! Thanks for verifying. :)

Note You need to log in before you can comment on or make changes to this bug.