Hyperlinks are highlighted when zooming with double tap

RESOLVED DUPLICATE of bug 719276

Status

()

Firefox for Android
General
P3
normal
RESOLVED DUPLICATE of bug 719276
6 years ago
a year ago

People

(Reporter: Camelia Urian, Assigned: wesj)

Tracking

12 Branch
ARM
Android
Points:
---

Firefox Tracking Flags

(fennec11+)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Build ID: Mozilla/5.0 (Android; Linux armv7l; rv:12.0a1) Gecko/20120108 Firefox/12.0a1 Fennec/12.0a1
Device: Samsung Nexus S
OS: Android 2.3

Steps to reproduce:
1. Go to www.mozilla.org
2. Double tap on hyperlink(image, link) to zoom in/zoom out

Expected results:
 Page is correctly zoomed in  and nothing is highlighted on page.

Actual results:
 Page is zoomed but hyperlink  is highlighted and remains highlighted until you tap somewhere else on the page

Comment 1

6 years ago
yeah, i see this too.  I don't like it at all :(
Assignee: nobody → cpeterson
tracking-fennec: --- → 11+
Priority: -- → P3
(Assignee)

Comment 2

6 years ago
Hmm... we should be clearing the the highlight here:

http://mxr.mozilla.org/mozilla-central/source/mobile/android/chrome/content/browser.js#2060

I'm guessing that an additional showpress event is also firing during double tap...

http://mxr.mozilla.org/mozilla-central/source/mobile/android/chrome/content/browser.js#2026
(Assignee)

Updated

6 years ago
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 719276
(Assignee)

Updated

6 years ago
Duplicate of this bug: 742014
(Assignee)

Comment 5

6 years ago
Created attachment 630335 [details] [diff] [review]
Patch

This makes us clear the highlight anytime the viewport changes. I can't reproduce if we do this, and it seems reasonable to me (but also... kinda awful).
Assignee: cpeterson → wjohnston
Attachment #630335 - Flags: review?(mark.finkle)
I don't really like this solution...
(Assignee)

Comment 7

6 years ago
Comment on attachment 630335 [details] [diff] [review]
Patch

OK. Lets find something better then. Back to the drawing board....
Attachment #630335 - Flags: review?(mark.finkle)
You need to log in before you can comment on or make changes to this bug.