Closed Bug 716602 Opened 9 years ago Closed 8 years ago

Crash when trying to use geolocation

Categories

(Firefox for Android :: General, defect, P2)

ARM
Android
defect

Tracking

()

RESOLVED INVALID
Tracking Status
fennec + ---

People

(Reporter: Margaret, Unassigned)

References

()

Details

(Keywords: crash, Whiteboard: [native-crash])

Attachments

(1 file)

Attached file logcat
This is happening on my local build (just updated to latest m-c), but I can't reproduce in Nightly.

Logcat attached (Atrix running 2.3.4).
To clarify, this is happening after I hit the "Share" button on the geolocation prompt. I was using http://gavinsharp.com/tmp/geo.html to test.
Severity: normal → critical
Keywords: crash
Whiteboard: [native-crash]
Assignee: nobody → doug.turner
tracking-fennec: --- → +
Priority: -- → P2
Margaret - Does your mozconfig use --disable-optimize ? I am trying to figure out if this (and other) debug build crashes is related to the general issue in bug 717441.
(In reply to Mark Finkle (:mfinkle) from comment #2)
> Margaret - Does your mozconfig use --disable-optimize ? I am trying to
> figure out if this (and other) debug build crashes is related to the general
> issue in bug 717441.

Yeah, it does. Here's my full mozconfig in case it helps:

mk_add_options MOZ_OBJDIR=@TOPSRCDIR@/obj-android
mk_add_options MOZ_MAKE_FLAGS="-s -j4"
ac_add_options --enable-debug
ac_add_options --disable-optimize
#ac_add_options --with-ccache
ac_add_options --disable-crashreporter

# Android SDK/NDK
ac_add_options --with-android-ndk="/Users/leibovic/code/android-ndk-r6b"
ac_add_options --with-android-sdk="/Users/leibovic/code/android-sdk-macosx/platforms/android-13"
ac_add_options --with-android-version=5
ac_add_options --with-android-tools="/Users/leibovic/code/android-sdk-macosx/tools"
ac_add_options --with-android-toolchain="/Users/leibovic/code/android-ndk-r6b/toolchains/arm-linux-androideabi-4.4.3/prebuilt/darwin-x86"
ac_add_options --with-android-platform="/Users/leibovic/code/android-ndk-r6b/platforms/android-5/arch-arm"

# Android options
ac_add_options --enable-application=mobile/android
ac_add_options --target=arm-linux-androideabi
ac_add_options --with-endian=little
i am not working on these right now.  resetting assignee.
Assignee: doug.turner → nobody
Margaret, are you still crashing with this still?
(In reply to Naoki Hirata :nhirata from comment #5)
> Margaret, are you still crashing with this still?

Yes, I was going to debug it with dougt in person one day, but we failed to do that. It's still only on my debug build.
I had this issue yesterday. While working on a bug fix, I was using ndk-r6b and my build was crashing, then switched to ndk-r6 and it worked fine. No idea why it happened, because I ended up not changing my .mozconfig, and I had been using ndk-r6b for previous builds from January until a couple of weeks ago.
sounds build/config issue. resolving as invalid. reopen if you see it again and have more info
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.