colors in telemetry histogram selector don't match the graph below

RESOLVED FIXED in Unreviewed

Status

Mozilla Metrics
Frontend Reports
RESOLVED FIXED
7 years ago
6 years ago

People

(Reporter: (dormant account), Assigned: Paulo Pires)

Tracking

unspecified
Unreviewed
x86
Windows 7

Details

Attachments

(2 attachments)

(Reporter)

Description

7 years ago
Created attachment 587161 [details]
screenshot

This lead me to believe we have a regression, but turned out the UI sneakily swapped colors :)


also note how the x axis is totally unreadable

Comment 1

7 years ago
Nice catch - I don't think it's a regression. We'll also work in the axis labels

Updated

7 years ago
Assignee: nobody → paulo.pires
(Reporter)

Comment 2

7 years ago
(In reply to Pedro Alves from comment #1)
> Nice catch - I don't think it's a regression. We'll also work in the axis
> labels

this almost gave me a heart attack.
(Reporter)

Comment 3

7 years ago
Also I noticed that if I select 3 parameters to compare by, the graph only gives me 2 colors. Can we fix that too while fixing this?
(Assignee)

Comment 4

7 years ago
The 2 colors was set when we first though only on a 2 variable compare, but since we can compare more than 2 variables the colors on the selector where removed and a palete of colors where added to the histogram for several variables.

The xAxis labels where fixed a few days ago, I added the 2 variables, 10.0a2 and 11.0a2, and it looks good. Are you selecting any other parameter so I can reproduce that histogram?
(Reporter)

Comment 5

7 years ago
(In reply to Paulo Pires from comment #4)

> 
> The xAxis labels where fixed a few days ago, I added the 2 variables, 10.0a2
> and 11.0a2, and it looks good. Are you selecting any other parameter so I
> can reproduce that histogram?

no, only changes are visible in the picture
(Assignee)

Comment 6

7 years ago
Created attachment 587637 [details]
screenshot

This is how I see it by selecting just 11.0a2 and 10.0a2 as you said.
Maybe you had another measure or check the date interval selected, but I think that the xAxis was fixed a few days ago, when we have more than 50 labels it shows only alternate labels.
(Assignee)

Updated

6 years ago
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.