View more information about this update link doesn't work

RESOLVED INVALID

Status

()

Toolkit
Application Update
--
major
RESOLVED INVALID
7 years ago
6 years ago

People

(Reporter: mkaply, Unassigned)

Tracking

Trunk
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
Created attachment 587166 [details]
Screenshot

I just got offered the new Firefox update and I got the attached dialog.

The link labeled "View more information" did nothing when clicked.
Component: Installer → Application Update
Product: Firefox → Toolkit
QA Contact: installer → application.update
What version are you using (bug is marked as trunk nut you have official branding)?
(Reporter)

Comment 2

7 years ago
Sorry about that. This was an 8.0 to 9.0 update, I believe (I got confused I was trying to update all my different versions). Unfortunately, when I killed it and then restarted, I did not receive the dialog again.

So I have no idea how to make that dialog reappear.
(Reporter)

Comment 3

7 years ago
And to be clear, I had no browser UI at this point. The only thing that was displayed was this dialog.
Did you try to update from that dialog or click next and if so, was it successful?
(In reply to Michael Kaply (mkaply) from comment #3)
> And to be clear, I had no browser UI at this point. The only thing that was
> displayed was this dialog.
Did the browser appear while the update ui was displayed?
(Reporter)

Comment 6

7 years ago
I did click next from the dialog and it started do the update. Honestly, I cancelled at that point because I realized I should have waited to debug the problem further.

When I restarted Firefox, I did not get that dialog and the only way to update was to use the about dialog.

> Did the browser appear while the update ui was displayed?

No, there was no browser UI at all while the update was happening. Just a progress indicator in the dialog itself.
That UI will display when an update must be confirmed by the user prior to updating. The weird thing is that is not blocking ui and doesn't prevent the browser from displaying ever.
(Reporter)

Comment 8

7 years ago
> That UI will display when an update must be confirmed by the user prior to updating. 

How does that happen?

Incompatible add-ons aren't checked until after the install happens, correct? So what could cause this particular dialog to be displayed?

(Trying to recreate)
(In reply to Michael Kaply (mkaply) from comment #8)
> > That UI will display when an update must be confirmed by the user prior to updating. 
> 
> How does that happen?
> 
> Incompatible add-ons aren't checked until after the install happens,
> correct? So what could cause this particular dialog to be displayed?
No... they are checked before updating.
(Reporter)

Comment 10

6 years ago
So should we close this as invalid?

I can't recreate and we don't know why it happened. Seems silly to keep it open just to sit here.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.